MPEG-4, AAC decoder, H.264 decoder are required

Hi,
I have been using Fedora Desktop for years but have decided to move away from it because the upgrade from Fedora 33 to 34 bricked the OS.
Thank you for making Rocky Linux available!
Given my experience with Fedora I like to think I can move my way around RL but I am having trouble with mp4 files.
When I try to play an mp4 file, Videos reports:
MPEG-4, AAC decoder, H.264 decoder are required
It then says to install via Software but when I go to Software, it reports 2 Gstreamer packages are installed, but I guess they are not providing the required codes.
I have tried the following:
Many dnf and Software searches such as “264”, “mp4” with no results.
dnf search gstream > provides many packages but I am not sure if this would be correct to install or which package to pick.
I tried installing rpmfusion but Software got hung up. (Assuming rpmfusion is a good thing to begin with).
I have also searched the fora here and only found:

Mp4 not playing and how 2 install VLC?

This suggests installing VLC but I would prefer just to get Videos working.
I have also web searched “H264 centos 8” and many other searches.
Help with the following questions is much appreciated:

  1. I think part of me not being able to find the right package is that I do not know which repos are supposed to be used with RL. Can rpmfusion repos work with RL? Centos 8 repos? RHEL 8 repos? Is there a list of repos that are supposed to be used with RL?

  2. How do I get Videos to work?

Thanks ahead of time.

Hi,

Thanks Tom.

Thanks for your help Tom

1 Like

Hello @RL1000

yes you can use rpmfusion repo

check this one Configuration - RPM Fusion

for command line you need

dnf install epel-release
to enable the epel repo

and the following from the link i mentioned

dnf install --nogpgcheck https://mirrors.rpmfusion.org/free/el/rpmfusion-free-release-8.noarch.rpm

dnf install --nogpgcheck https://mirrors.rpmfusion.org/nonfree/el/rpmfusion-nonfree-release-8.noarch.rpm

dnf config-manager --enable powertools

dnf groupupdate core

dnf groupupdate multimedia --setop="install_weak_deps=False" --exclude=PackageKit-gstreamer-plugin

dnf groupupdate sound-and-video

hope that help and have a nice day :slight_smile:

1 Like

Hi @ JustSomeone

Thank you very much for taking the time to answer my post and the help.

I wont have a chance to try it for a few days, but just wanted to say thanks.

1 Like

you very welcome and take your time :slight_smile:

That worked like a charm JustSomeone, thanks! I marked it as Solution.

1 Like

For anyone that may have this issue in future, to save them some time, the first response is this issue, which was about:

How to install VLC Player on CentOS 8 / RHEL 8 Linux

Did not work.
Also the repos were already installed (by default I presume).

Also this response did not answer my questions which were about which repos can be used with RL and how to install codecs without installing VLC.

you very welcome @RL1000 :slight_smile: