Mkksiso not working?

I am trying to add a custom Kickstart to a Rocky iso for unattended installation.

Using
mkksiso --ks ks1.cfg Rocky-9.3-x86_64-minimal.iso Rocky-9.3-x86_64-minimal-custom.iso
if I boot the custom iso, when pressing ‘e’ on the grub options on first boot there is no inst.ks options inserted into grub.cfg, and so the installer boots to the standard installer UI.

Inspecting the custom iso by mounting it I see the ks1.cfg in root, and /EFI/BOOT/grub.cfg has the inst.ks options.

Opening the CLI with ctrl + alt +f2 in the installer UI, I see the ks1.cfg in /run/install/sources/mount-0000-cdrom and I see the updated grub.cfg with the inst.ks options in /run/install/sources/mount-0000-cdrom/EFI/BOOT.

I would really appreciate any pointing in the right direction to get this working.

You’ve added a kickstart with mkksiso… but have you even tried it? What’s the actual issue you’re having?

The Kickstart is very basic, but the issue I am having is that the Kickstart file is not even being looked at. When booting to the custom iso and pressing the ‘e’ button to edit the grub text, the inst.ks option does not exist.

Would someone else mind trying to do this? This functionality is quite basic and I cannot see anything I am doing wrong. Surely anyone doing this exact thing will have the same outcome I am having?