Missing gsetting key for flatpak apps?

I’m running Rocky Linux 9.3 with a GNOME 40 desktop.

I installed a few GTK4 libAdwaita apps via flatpak that run in the GNOME 45 runtime.

For example the Eyedropper app from flathub.

When I run any GTK4 libAdwaita flatpak app via command line, I see this error:

[hugh@localhost ~]$ flatpak run com.github.finefindus.eyedropper
...
(eyedropper:2): Adwaita-WARNING **: 19:57:40.485: Invalid color scheme  (Expected one of: default, prefer-dark, prefer-light)

I believe that libAdwaita apps get the color scheme preference from ‘gsettings’:

org.gnome.desktop.interface color-scheme

I think that setting was introduced after GNOME 40, so the ‘color-scheme’ key doesn’t exist on my system.

[hugh@localhost ~]$ gsettings get org.gnome.desktop.interface color-scheme
No such key “color-scheme”

Can I just create the missing key? How?

Are local ‘gsettings’ passed to the flatpak apps running in their container?

What is the preferred method of setting the “color-scheme” gsetting key for flatpak apps?

I tried Googling it but everyone keeps saying to pass a GTK_THEME env variable to flatpak apps. This is not what I want. I don’t want to change the theme of libAdwaita apps (it breaks too many things). I just want to toggle the dark or light mode.