Installing Server GUI after minimal v9.3 installation

I recently installed a minimal server from freshly downloaded 9.3 minimal ISO, then proceeded to configure it and install more packages. At one point, I enabled the EPEL release to get some packages as well.
After I was all done, I wanted to do a group install of the “Server with GUI” group. However, it spit out the following errors indicating there’s a resource/dependency missing.

dnf group install "Server with GUI"
Last metadata expiration check: 1:45:56 ago on Sat 20 Jan 2024 12:10:01 AM EST.
No match for group package "insights-client"
No match for group package "centos-stream-release-eula"
No match for group package "hpijs"
Error:
 Problem: cannot install the best candidate for the job
  - nothing provides insights-client needed by rhc-1:0.2.4-3.el8.x86_64
(try to add '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages)

I know this is normally doable, as I’ve done it on CentOS v6, v7 and v8 servers without fail.
I did find a post that outlines where this bug was introduced, and fixed, and I think that will point out where the Rocky developers missed something:
https://bugzilla.redhat.com/show_bug.cgi?id=2064944
down toward the end of the post, Troy Dawson, back in 2022, indicates how the bug was introduced, and how he fixed it in the build. Not sure how that made it into v9 if it had already been resolved, but here we are.
Thanks.

I’m seeing multiple issues here with the question and your console output.

You say you installed 9.3 minimal and configured your system, including installing epel-release. Why is your output showing centos-stream-release-eula, insights-client, and rhc? Why is your output showing el8?

How exactly did you configure this system? Are you sure this is Rocky Linux 9? It seems to me you have mixed many repos together and you are no longer running a Rocky Linux 9 system.

We do not provide insights-client nor rhc.

[root@xmpp01 ~]# dnf search insights-client rhc
Last metadata expiration check: 1:58:20 ago on Fri 19 Jan 2024 10:15:26 PM MST.
No matches found.

# no results for those packages in our groups
[label@sani comps]$ grep rhc comps-rocky-9.3.xml
[label@sani comps]$ grep insights comps-rocky-9.3.xml
[label@sani comps]$

Well, well, well.
You are correct - there’s definitely a problem with that output - I should be a little more careful which Putty window I’m typing in :slight_smile:
I had been working on this for most of the day, and had 5 different windows open accessing a couple different servers for stuff, and yes, I tried to install that on the wrong system, and one that already had the GUI already installed :slight_smile:
So my apologies. I guess my last minute, 2am, “I’ll do this quick before I head off to bed” effort went sideways - thanks for catching it!
tldr; operator error
Thanks!
(it installed on the correct server without an issue)

1 Like