Installing openmpi rockylinux 9.2 issues

Hi, I am trying to install openmpi 4.1.6 on a recently installed rockylinux 9.2. I know little about linux, I just want to get this set up to use other software dependant on it. It seems ok, get the following output from retrying an install.

[root@localhost openmpi-4.1.6]# dnf install openmpi openmpi-devel
Last metadata expiration check: 0:47:31 ago on Mon 16 Oct 2023 08:43:57.
Package openmpi-1:4.1.1-5.el9.x86_64 is already installed.
Package openmpi-devel-1:4.1.1-5.el9.x86_64 is already installed.
Dependencies resolved.
Nothing to do.

from the following it doesnt seem that the executable is in the path where I need it to be

[root@localhost openmpi-4.1.6]# which openmpi
/usr/bin/which: no openmpi in (/root/orca:/root/.local/bin:/root/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin)

If I try the following it tells me the package is not installed.

[root@localhost ~]# rpm -ql openmpi*
package openmpi* is not installed

Any suggestion would be welcome, thanks

The -l is --list as in list files in package. With wildcard you do need -a (the --all):

rpm -qa openmpi*

but dnf can show the same (and more) with:

dnf list openmpi*

It is possible to have more than one MPI implementation (at least 32-bit and 64-bit openmpi, and mpich).
However, only one can be first of PATH. The packages resolve that with environment modules. See Environment Modules (software) - Wikipedia

That is installed on your system. You can try commands:

module av
module load mpi
module list

When a mpi module is loaded, its commands and libraries are visible.

PS. Do not run “applications” as account “root”. Do work with regular account and only maintenance with root.

Thank you for your help and advice, greatly appreciated. I have solved the issue now. Also with the help of the instructions here: Rangsiman Ketkaew - Installation of OpenMPI

I installed version 4.1.1 from /usr/local as in the link and the path to mpirun is /usr/local/openmpi-4.1.1.

I use it with ORCA for computational chemistry and needed parallel computing and all worked ok after a server restart.

export PATH=$PATH:/usr/local/openmpi-4.1.1/bin/
export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/usr/local/openmpi-4.1.1/lib

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.