Installation of monitoring tools

Just finished installing Rocky 8.4 GA release in a V Box and I managed to install and configure Nagios 4.4.6 and Zabbix 5.0 . Everything is working properly.

4 Likes

Nice to know, might have to try Zabbix sometime.

I personally use CheckMK, with the appropriate check-mk-agent for monitoring. There’s a ton of plugins as well for additional application monitoring. It can also use Nagios plugins if a native CheckMK one isn’t available. I tested CheckMK 2.0.0p6 with Rocky, installs fine and works good so far.

2 Likes

Thank you iwalker for your information.
I never heard of CheckMK but I will try.

Hi
i used Zabbix a long time ago which is great , now i mainly use pandoraFMS , just give it a try , it a wonderful solution and very easy to install and manage

good luck

1 Like

Hi

I tried it long time before. I will see.

Thanks for your suggestion

1 Like

my pleasure :slightly_smiling_face:

let us know when you test it

1 Like

We had some people interested in running OpenNMS on Rocky Linux as well and we got positive feedback that OpenNMS Horizon 28+ with the RHEL/CentOS instructions work without any issues.

1 Like

This is good to hear. My shop is currently using Xymon for monitoring (and I can confirm that the xymon-client from Terabithia installs beautifully on Rocky), but we’ve been waiting for Rocky GA to begin exploring a transition to Zabbix. Glad to know @beniksh has already gotten to this, and it’s proven to work as expected!

Hello iwalker,

I was installing and configuring CheckMK v.2 with Rocky. Everything was fine, easy to install and configure.

Thank you!

2 Likes

Did anyone successefully installed nagios agent on rocky?
I get the message “Rocky is not currently supported. Please use either Red Hat, CentOS, Oracle Linux, CloudLinux, SUSE Enterprise, OpenSUSE, Ubuntu, or Debian.”

I am downloading officiall NRPE agent from
https://assets.nagios.com/downloads/nagiosxi/agents/linux-nrpe-agent.tar.gz

Hello,

Did you try from Epel repository? From there seems to be ok.

All the best.

1 Like

Tried epel but then realised that I would have to do a lot of workarounds to get this working with my remote nagios server because i found errors like this when executing nrpe check from remote:
[pid 55280] execve("/usr/local/nagios/libexec/check_cpu_stats.sh", ["/usr/local/nagios/libexec/check_cpu_stats.sh", “-w”, “85”, “-c”, “95”], 0x562f93bdb730 / 11 vars /) = -1 ENOENT (No such file or directory)
, so i finally took official NRPE agent and added support for Rocky linux.
Now it works like a charm…

Thanks anyway.

Since we’re talking about monitoring tools, collectd from EPEL works just fine, as expected. I have it configured to report into influxdb on a central server, with grafana reporting.

Instead of being a monolith rpm the different plugins are in different packages; eg collectd-disk is needed for the “disk” plugin.

I use collectd from centos-release-opstools.