Initializing network after system installation

You do have two connections defined, but they are down for some reason. Within the output of these:

nmcli -f connection con show ens1f0np0
nmcli -f connection con show ens1f1np1

… should be field “autoconnect”. That field tells whether NetworkManager attempts to start connections automatically (on boot & on link).

You also have two devices (note, the nmcli device state or nmcli d s for short shows more compact version than the show).
They would not show up, if you had no driver. Without driver you see something only with lspci.
With lspci -nn there is also device ID (in brackets). The ID is precise description of the device.

You can also look at logs (of service) with:

sudo journalctl -u NetworkManager

Thank you jlehtone and prasad! The things continue to surprise me:

  1. Trying to auto-connect by setting the connection up fails, however as soon as I set a static IP address the connection was successful:
    However a subsequent attempt switching to the dynamic IP (as long as I understand this is what autoconnect parameter does) failed again. What can cause this?
  2. OK, I seem to be connected according to the nmcli report - but all my attempts pinging another network nodes (except for the self, by fail. What might that be?
  3. I tried using the journalct1 command only to be kicked off with the “command not found”. Should I install this service additionally somehow?
    Thank you once again,
    Mike F

journalctl is installed by default. The last character is a lower case “L” and not a numeral 1 as observed in your post.

jbkt23, thank you! My bad! Still, this is the secondary issue…

The 'man nm-settings writes:

connection settings
Whether or not the connection should be automatically connected by NetworkManager when the resources for the connection are available. TRUE to automatically activate the connection, FALSE to require manual intervention to activate the connection.


ipv4 settings
IP configuration method.

NMSettingIP4Config and NMSettingIP6Config both support “disabled”, “auto”, “manual”, and “link-local”. See the subclass-specific documentation for other values.

In general, for the “auto” method, properties such as “dns” and “routes” specify information that is added on to the information returned from automatic configuration. The “ignore-auto-routes” and “ignore-auto-dns” properties modify this behavior.

In other words:

  • connection.autoconnect says whether connection should start on boot, regardless of method. You want yes there
  • ipv4.method says how to configure IPv4 settings (auto = with DHCP, manual = static values)

The machine/port does not seem to be connected and the issue is not the IPv4 config.

What is the output of lspci -nn | grep -i net ? (The device ID that is in brackets?)

I appreciate the enthusiasm!
I look forward to new additions!
But I don’t understand why after registering in this forum the first article is not reviewed?

Not sought and seen what it says here:
With a direct link and an answer to your question.

Hi jlehtone,
here is the output of the suggested lspci command:

Now what I found out is that the assigned static IP cannot be pinged from the outside, which tells me that there is still something wrong in thte network configuration. Will try to investigate as much as possible…

Best regards,
Mike F

Xino, thank you! Didn’t help unfortunately :frowning:
The external nodes are not visible, and this machine cannot be pinged from another nodes as well…

Mike F

On the contrary!
This is the solution.
The question is whether you know what is required for the network setup of this host in question.
Since you don’t say what you see and/or have set up in nmtui
Is there at least a default gateway set up?
Is there a specified DNS?
Is there a working firewall?
It is incorrect to say that you were not provided with documentation as you requested.
Please answer the question, do you know what is required and necessary for the network this host is running on.
For example: it is enough to enter a wrong mask and your host will never be accessible from outside.
For this, please help with correct information, we will also help you.

Looks like the host has trouble getting IP from DHCP. Remove the static IP and run dhclient ens1f0np0 command. If the interface no IP assigned then you need to check your LAN network for firewall or NAT issues.

Successful dhclient command will emit logs something like below output to /var/log/messages file :

messages:Jul 12 18:21:05 desktop dhclient[4863]: DHCPOFFER of from
messages:Jul 12 18:21:05 desktop dhclient[4863]: DHCPREQUEST for on enp4s0 to port 67 (xid=0x26dbaa74)
messages:Jul 12 18:21:05 desktop dhclient[4863]: DHCPACK of from (xid=0x26dbaa74)
messages:Jul 12 18:21:07 desktop NET[4913]: /usr/sbin/dhclient-script : updated /etc/resolv.conf
messages:Jul 12 18:21:07 desktop dhclient[4863]: bound to -- renewal in 3578 seconds.```

Let me add something for DHCP client of NetworkManager
The built-in DHCP client does not work correctly with relayed DHCP servers in to large network of ISP.
I highly recommend install dhclient - ISC DHCP
dnf install dhclient
Not forgetting to tell NetworkManager to use it.

1 Like

Hi Xino and prasad, thank you so much for your input. I was away from the case these days unfortunately but now i am slowly (ugh!) getting back to it. Now to answer your questions.

  1. Yes, I know how to set up network in general - did it zillion times on Windows machines;
  2. The configuration I was using - in nmtui - looks like follows:

    I believe this is a legit configuration.
  3. Now I followed prasad’s advice and turned off static IP assignment. The nmtui screen displays as In the next post (I cannot post more than one attachment)
  4. It changed nothing as far as I am concerned. However when I tried running the dhclient command like: dhclient ens1f0np0, the response was like in the second following post
  5. I ran nmcli and this is what I saw I will post in the third post after this
  6. Still, I cannot ping anything (both external addresses and the server itself from the outside).
  7. Yes, theoretically the physical connection may be at fault (I will double-check it when in the office :)) but I am using a brand new cable and it is connected through a dump 4-port hub, all other ports of it work just fine…

Best regards,
Mike F.




In the screenshot shown with the static addresses, why is auto connect not enabled?

What works and what doesn’t?
Is routing, forwarding checked?
Is the firewall stopped?

cat /etc/NetworkManager/conf.d/dhcp-client.conf

For comparison, this port has no cable on it:

# ip li sh dev ens7f3
5: ens7f3: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc mq state DOWN mode DEFAULT group default qlen 1000
    link/ether 00:19:99:8d:cc:aa brd ff:ff:ff:ff:ff:ff
    altname enp2s0f3

# nmcli d show ens7f3
GENERAL.DEVICE:                         ens7f3
GENERAL.TYPE:                           ethernet
GENERAL.HWADDR:                         00:19:99:8D:CC:AA
GENERAL.MTU:                            1500
GENERAL.STATE:                          30 (disconnected)
GENERAL.CONNECTION:                     --
GENERAL.CON-PATH:                       --
IP4.GATEWAY:                            --
IP6.GATEWAY:                            --

It has state 30 (disconnected), just like OP in one of the screenshots (but OP had carrier on).

Hi Xino and jlehtone,
Thanks for response! Here is the thing.

  1. It seems like therefis no dhcp-client.conf file in the /etc/NetworkManager/conf.d - in fact this directory is empty :frowning:
  2. The screenshot with the responses to the suggested checks is presented below (note that the device state is 100 (connected)

    Best regards,
    Mike F.


And which client does the connectivity then?

journalctl -b | grep -i error
journalctl -b | grep -i dhclient

What works and what doesn’t?
Is routing, forwarding checked?
Is the firewall stopped?

arp -a | grep “”

Let me answer the questions so that the problem can be solved, please!
I don’t want to force the words out of your mouth!
If you’re uncomfortable answering the questions, do a clean install again.

If there is link, then what drops the packets?
What else could we query about the system?

# Any other machines seen by this machine:
# or
ip neigh

# Information about the interface:
ethtool ens1f0np0
ethtool -i ens1f0np0

# Link statistics
ip -s ad