How to display boot messages on console

I would like to see the Rocky Linux 9.3 boot messages on the console, but they are not showing up. I have removed ‘rhgb’ from the grub default file and used grub2-mkconfig to rebuild the grub2.cfg files. I have used grubby to remove it from the kernel lines. And I have verified there is no kernelopts line in grubenv.

If I also remove ‘quiet’ them I get all the messages, along with a pile of diagnostic msgs that I do not want.

What do I need to change to have the messages appear but not remove quiet from the kernelopts?

Thank you - Justus

What’s your current /proc/cmdline? What diagnostic messages are you trying to avoid?

According to The kernel's command-line parameters — The Linux Kernel documentation

quiet [KNL] Disable most log messages

If you want to see more than what quiet shows, then you can’t use quiet.

Villy Kruse does mention in Unknown Kernel command line parameters - Fedora Discussion
that one can adjust log level. There is loglevel= kernel parameter to do that for boot.

The command line is:

BOOT_IMAGE=(hd0,gpt2)/vmlinuz-5.14.0-362.8.1.el9_3.x86_64 root=/dev/mapper/vg00-lv_root ro quiet crashkernel=1G-4G:192M,4G-64G:256M,64G-:512M resume=/dev/mapper/vg00-lv_swap rd.lvm.lv=vg00/lv_root rd.lvm.lv=vg00/lv_swap selinux=0

On another 9.3 system that I upgraded from 9.0 to 9.1 to 9.2 to 9.3 the command line is

BOOT_IMAGE=(hd0,gpt2)/vmlinuz-5.14.0-362.13.1.el9_3.x86_64 root=/dev/mapper/vg00-lv_root ro crashkernel=1G-4G:192M,4G-64G:256M,64G-:512M resume=/dev/mapper/vg00-lv_swap rd.lvm.lv=vg00/lv_root rd.lvm.lv=vg00/lv_swap quiet selinux=0

And that 2nd system boots displaying all the messages that I want to see, each service starting (systemd output). Interestingly, if I build the system as minimal with no extra packages, the default is to display all messages, quiet is missing in this default build. If I add quiet, but not rhgb, then I get the messages I’m looking for. If I add the ‘system-tools’ and ‘security-tools’ to the kickstart build then I can’t get the messages to display.

Both have ‘quiet’ and yet one produces the output I am looking for that the other does not. Maybe some setting in systemd that is different depending the packages used to build the server?

@jlehtone, the docs you pointed to appear to be for the 6.7 kernel, but these systems are running 5.14.

An apparent difference is the location of the ‘quiet’ on the list. Could that affect behaviour?

True, but should we expect huge changes in options, like the quiet, which definitely are not new?


The security-tools has only one non-optional package, scap-security-guide, which is just documentation?