How to change the Plymouth Boot Screen in Rocky Linux 8.9 when Nvidia proprietary drivers are installed?

I attempted to modify the Plymouth boot screen on specific hardware running Rocky 8.9 and Gnome for a graphical user interface. Despite installing Plymouth and various themes, the desired boot screen does not display correctly on the hardware, which includes an Nvidia card [Quadro P2000]. Interestingly, the customization works successfully with Nouveau drivers but encounters issues with Nvidia proprietary drivers.

Currently, it shows the 3 dots during the boot after blocking the Nouveau drivers.

To change the Plymouth boot screen, I am using the below commands

plymouth-set-default-theme -R <theme name>

image

Disabling the nouveau driver from the grub command line and adding the blacklist conf in the /etc/modprobe.d path.

image

Would appreciate your assistance.

How did you install the nvidia drivers? Using the .run file from NVidia’s website, or using the drivers in rpmfusion repository? Usually the .run drivers cause majority of problems, and recommended to use the rpmfusion ones.

I am not using .run. I am making the Nvidia rpms as part of ISO. it gets installed if a Nvidia controller is present in the system.
Well, I don’t see any issue while working with the Nvidia driver. It’s just the boot screen always shows to same screen irrespective of what theme we choose.

I don’t know what nvidia’s driver packages do, but it sounds like to me you are missing some other specific steps other than disabling nouveau (which nvidia’s packages don’t seem to do, unsurprisingly).

With that said, using -R (to rebuild the initrd) when setting a theme isn’t enough when you start using the proprietary drivers. Plymouth and nvidia do not get along. You should look into modifying dracut and modprobe.d. But there are no guarantees that will work for you.

% cat /etc/modprobe.d/blacklist.conf
blacklist nouveau

% grubby --update-kernel=ALL --args="rd.driver.blacklist=nouveau nvidia-drm.modeset=1"

% cat /etc/modprobe.d/nvidia.conf
options nvidia_drm modeset=1

% cat /etc/dracut.conf.d/nvidia.conf
add_drivers+=" nvidia nvidia_modeset nvidia_uvm nvidia_drm "
install_items+=" /etc/modprobe.d/nvidia.conf "

% dracut -f

Good luck.

I had tried these configuration changes and this doesn’t seem to be working.

Tried with the below changes again and got the same result.

I am creating new initramfs using dracut -f command.