Gaming in Rocky

I know that Rocky is business oriented, but I like to play aisleriot (solitaire)t sometimes . I can not
install it. Help! Thanks

You need to check the exact dependencies that it expects to find on the target system, and also analyze the install script that you tried to run, and find out which part is failing.

I tried to install extra repositories and ran “dnf install aisleriot”. I’m used to Debian.

If RPM resource aisleriot and Aisleriot Download (APK, DEB, EOPKG, PKG, RPM, TXZ, XBPS, XZ, ZST) are reliable, then there is no package ‘aisleriot’ for EL8.

There are packages for EL7 and some Fedora versions. One could take their source RPM, e.g. https://download.fedoraproject.org/pub/epel/7/SRPMS/Packages/a/aisleriot-3.22.2-1.el7.src.rpm
and see if that can be rebuilt for EL8 target. (Rebuild as regular account.)
‘mock’ is often recommended as the rebuilding tool.

I compiled and installed aisleriot-3.22.9-3.el8.x86_64.rpm on my computers a while back. I don’t recall that there was anything special involved to do that.

I have a bunch of rpms that I’ve compiled for el8 that don’t seem to exist anywhere else, ranging from actually useful stuff to stuff that’s just cool; from calcurse to cdk to ponysay. :slight_smile:
I keep meaning to make a webpage for anyone else who might find this stuff useful but somehow I haven’t got around to it.

I have no idea how to compile and install anything. If you could upload could upload them that would be great. No AUR? Would it be to large to e-mail? Thanks

You could add “page” to COPR:
https://copr.fedorainfracloud.org/

I’m guessing this is the official url for it

It says it has “eighty” different games?
My first question; is this 100% free and open source, and where is the source code?

From Fedora it links to Gnome website:

[root@elise ian]# dnf info aisleriot
Last metadata expiration check: 2:56:49 ago on Thu 24 Mar 2022 13:43:09 CET.
Available Packages
Name         : aisleriot
Epoch        : 1
Version      : 3.22.21
Release      : 1.fc35
Architecture : x86_64
Size         : 6.2 M
Source       : aisleriot-3.22.21-1.fc35.src.rpm
Repository   : updates
Summary      : A collection of card games
URL          : https://wiki.gnome.org/Apps/Aisleriot
License      : GPLv3+ and LGPLv3+ and GFDL
Description  : Aisleriot is a collection of over 80 card games programmed in scheme.

https://wiki.gnome.org/Apps/Aisleriot

From that link is a gitlab link to clone it. Most likely can be built from it too.

OK, looks like a meson build, which should be possible.

Just a few urls away is “Gnome Chess” which I was hoping to build anyway.

# Requirements
cairo_req_version           = '1.10.0'
gconf_req_version           = '2.0'
gio_req_version             = '2.32.0'
glib_req_version            = '2.32.0'
gtk_req_version             = '3.18.0'
guile_2_0_req_version       = '2.0.0'
guile_2_2_req_version       = '2.2.0'
guile_3_0_req_version       = '3.0.0'
libcanberra_gtk_req_version = '0.26'
qt5svg_req_version          = '5.0.0'
rsvg_req_version            = '2.32.0'

The last two entries are worth an other look. It would appear that you can choose between ‘qt5’ and ‘r’, but ‘qt5’ has a lot of overhead, so try ‘r’ in the first instance.

In addition, I think Rocky 8.5 only has guile 2.0.

Interesting, they have some “distro” tests, and ‘rocky’ isn’t on the list yet.

They don’t actually say how to build, install and run it. Assuming standard meson workfolow, I was able to build it, but it won’t run yet - it can’t find the theme. It has two different options for conf settings; GConf and “normal”.

http://melvilletheatre.com/aisleriot-3.22.9-3.el8.x86_64.rpm

In general, you should not be installing random rpms (especially as root).
I’m not saying there’s anything wrong with the rpm, but you are essentially installing a closed source binary, and it would only take ten minutes to add a backdoor it. A possible alternative would be to offer a source rpm; the user can then decide if it’s safe.

You’re right to a certain point, but that doesn’t solve the problem at hand.

He is unable to compile his own binary from source for whatever reason, so I’ve put the one that I compiled for my own use up for him to download.

I compiled it from aisleriot-3.22.9-3.fc32.src.rpm. That file is easily available for download from several sources, so anyone who wants to compile their own can do what I did and download that and compile for themselves. As I said above, there isn’t anything particularly spectacular involved here; I have a binary rpm that I use myself and if anyone else wants to use it you’re welcome to do so.

I have now been able to build and run the program and play the ‘klondike’ game. This is using only packages from the official Rocky repos. Right now, I can only play the ‘klondike’ game, and some paths are a bit off. I’ll post the HowTo when it’s fixed.

I don’t know why you’re making such a big production out of this.

The aisleriot-3.22.9-3.fc32.src.rpm compiles pretty much right out-of-the box and all of the games work (as far as I know).

Are there some other issues here that I’m not seeing?

Regarding the source rpm ‘aisleriot-3.22.9-3.fc32.src.rpm’, I notice ‘fc32’ as opposed to ‘fc35’, which I’m guessing is becuase Rocky needs an older version? The actual source code is also a bit older being 3.22.9 as opposed to 3.22.22.

Fedora 35 and Rawhide have aisleriot-3.22.21-1 sources and both fail –
mock -r rocky-8-x86_64 --rebuild aisleriot-3.22.21-1.fc35.src.rpm stops at:

No matching package to install: ‘pkgconfig(guile-3.0)’

I had mock -r rocky-8-x86_64 --rebuild aisleriot-3.22.9-3.fc32.src.rpm stop on some other error, and with -r rocky+epel-8-x86_64 ran out of disk space. Not running Rocky, not familiar with mock, and my academic interest does not get further than this.

regarding aisleriot-3.22.21-1.fc35.src.rpm, it makes sense it won’t work, because guile 3.0 doesn’t exist in Rocky 8.5

I made some progress; the broken paths are now working, many of the errors have gone and the whole list of games now show as available. I need to clean everything and rebuild with simplified params.

Thanks guys. I didn’t know it would be so hard.