Double install attemp by dnf

[root@server5 ~]# dnf -y update && reboot && exit
ookla_speedtest-cli                             645  B/s | 833  B     00:01
ookla_speedtest-cli-source                      583  B/s | 833  B     00:01
Error:
 Problem 1: package openssl-devel-1:3.5.8-1.el9_8.x86_64 from @System requires o                                                                                                              penssl-libs(x86-64) = 1:3.5.8-1.el9_8, but none of the providers can be installe                                                                                                              d
  - cannot install both openssl-libs-1:3.5.8-2.el9_8.x86_64 from baseos and open                                                                                                              ssl-libs-1:3.5.8-1.el9_8.x86_64 from @System
  - cannot install both openssl-libs-1:3.5.8-2.el9_8.x86_64 from baseos and open                                                                                                              ssl-libs-1:3.5.8-1.el9_8.x86_64 from baseos
  - cannot install both openssl-libs-1:3.5.8-1.el9_8.x86_64 from devel and opens                                                                                                              sl-libs-1:3.5.8-2.el9_8.x86_64 from baseos
  - cannot install the best update candidate for package openssl-libs-1:3.5.8-1.                                                                                                              el9_8.x86_64
  - cannot install the best update candidate for package openssl-devel-1:3.5.8-1                                                                                                              .el9_8.x86_64
 Problem 2: package php-devel-8.4.26-1.module_php.8.4.el9.remi.x86_64 from @Syst                                                                                                              em requires openssl-devel(x86-64) >= 1.0.2, but none of the providers can be ins                                                                                                              talled
 

It appears to me that the php-devel from the remi repository requires openssl-devel version that is incompatible with the version available from rocky. It would seem that the remi repo needs to update their version of php-devel to be compatible with the latest rocky updates.

The problem is obviously not related to my repository (remirepo)

php-devel requires openssl-devel with no version

I think the issue is actually that you’re getting different mirrors for devel and baseos, and the devel mirror you’re getting doesn’t have the latest openssl-devel. Maybe run dnf clean all, and then try again?

openssl-devel doesn’t normally come from the ‘devel’ repo, it comes from ‘appstream’, and the ‘devel’ repo is normally disabled. I can see right now that ‘devel’ does have openssl-devel-1:3.5.8-2.el9_8.x86_64, so the error might change (or go away)

I updated with:

 dnf -y update --allowerasing

This woked