DNF makecache error - Rocky 9

I notice in the logs that dnf makecache which runs periodically gets an error as follows:

“Error: Failed to download metadata for repo ‘extras’: Cannot download repomd.xml: Curl error (56): Failure when receiving data from the peer for http://mirror.atl.genesisadaptive.com/rocky/9.1/extras/x86_64/os/repodata/repomd.xml [Recv failure: Connection reset by peer]”

My repos are:

dnf repolist
repo id repo name
appstream Rocky Linux 9 - AppStream
baseos Rocky Linux 9 - BaseOS
crb Rocky Linux 9 - CRB
droplet-agent DigitalOcean Droplet Agent
epel Extra Packages for Enterprise Linux 9 - x86_64
epel-next Extra Packages for Enterprise Linux 9 - Next - x86_64
extras Rocky Linux 9 - Extras
remi-modular Remi’s Modular repository for Enterprise Linux 9 - x86_64
remi-safe Safe Remi’s RPM repository for Enterprise Linux 9 - x86_64

I upgraded this system in place from rocky 8. I am wondering if the “extras” repo isn’t valid for Rocky 9?

When I browse to http://mirror.atl.genesisadaptive.com/rocky/9.1/extras/x86_64/os/repodata/repomd.xml, the file does exist so I’m not sure what is going on.

Hmm just tried manually running the service and it worked. Maybe some sort of intermittent problem with the mirror.