Disable modular filtering in kickstart config file

How do i disable modular filtering for a repo i have listed in my kickstart.cfg file? I need to disable modular filtering for the elrepo repository.

There should, in general, not be a reason to set module_hotfixes or disable modular filtering. There are very few reasons to ever do this.

It would be helpful to everyone know what the error is and what you’re running into. Please provide screenshots or logs to your issue to help determine the actual cause of your issue.

When installing kmod-nvidia, nvidia-x11-drv and nvidia-x11-drv-libs in the kickstart. Before the kickstart starts installing i get the message attached in the screen shots.


ELRepo seems to have now:

kmod-nvidia-535.129.03-1.el8_8.elrepo.x86_64.rpm
kmod-nvidia-535.129.03-2.el8_9.elrepo.x86_64.rpm
nvidia-x11-drv-535.129.03-1.el8_8.elrepo.x86_64.rpm
nvidia-x11-drv-535.129.03-2.el8_9.elrepo.x86_64.rpm

Where is the 535.113.01 coming from (and why still 8.8 install when 8.9 is already out)?

Besides, ELRepo does not seem to have modules.yaml – if the repo has no module metadata, then the error message is misleading.


These days I do use kickstart to make initial minimal install at most, and handle all configuration (and install of most packages) with Ansible afterwards. One could probably run Ansible playbook in the post stage.

So I have elrepo added to my kickstart. I have an internal repository sever which has all the packages including those nvidia ones in that repo.

Reason 8.8 is because we are 3 quarter of av way through our testing on Rocky8.8. I plan to upgrade to 8.9 at a later date but that still won’t solve the above issue which I have not enountered before.

535.113.01 is coming from elrepo.

If you have collected packages to your own repository, then its metadata must have been generated all by you, including possible “modular” bits. If the repo has only the packages that you want, then it has no need for modules to be defined, has it?


You could have more than one local repo, with one for packages sans modules and another for those that must have modules.


You could replace the ELRepo packages with the 535.129.03-1.el8_8 versions, since that is still “8.8”, although that might not affect this issue either.

So i reprovosioned the whole of the elrepo repository to my internal repository. I never had this issue about modular until 2 days ago. Nothing has changed in the repo. Looks like it can find the rpms in the 1st screen shot but then in the other screen shot I get

Problems in request:
missing packages: nvidia-x11-drv

Is filtered out by modular filtering. I never enabled this.

How are you syncing the repositories? Are you using reposync against the 8.8 vault and then doing createrepo after? If so, you are destroying certain metadata when doing so. I would suggest keeping all repos separate from each other and not mess with the metadata.

If you absolutely insist on having packages combined together, ensure you are using createrepo --update.

So the commands i use are

reposync --gpgcheck --config=/etc/yum.repos.d/elrepo8.8.repo --repoid=elrepo8.8 --delete --download-path /home/www/html/repos/rocky/ --downloadcomps --download-metadata

I tried with and without the below command but still get the same issue

createrepo --update -v /home/www/html/repos/rocky/elrepo8.8

So finally found the culprit. It was nothing to do with my elrepo repository. It was because of one of my other repositories but the error was not clear. After hashing that repo out the install went through without complaining about my nvidia drivers. Thanks for all your help.

2 Likes