Crash at installation time

Hi there
I was working with CentOS on my laptop for years, now Centos 7 on lenovo thinkpad W540, but as you know forced to change now; my choice was RL and I tried it (V 8.8 and 9.2) on my virtual environment with two different KVM: they worked smoothly, no problem at all on both.
So I decided to make a fresh 9.2 installation on a new hard drive to build a new working env and then transfer all my personal data there, but immediately I got into trouble because installation crashed just after initial screen where I choose “to install” or “test media and install” or etc…
with the errors you can see in the following screenshots, similar for both versions.

  • I used the same SHA256 checksum verified ISO files for installing virtual machines and fresh new hard drive installation;
  • starting installation from a bootable USB stick I had just one installation shot, then USB stick get unusable;
  • then I copied (dd) the ISO file on an external USB hard drive, and I could do multiple unsuccesful attempts
  • I updated my laptop BIOS to the last available 06/2021
    Any clue on what I can do to start enjoy working with RL?
    Thanks for any help

In the BIOS, is the TPM chip enabled? Do you have an option to enable it there? I think that is what is missing here, but I’m not sure.

1 Like

I have an older Dell Latitude E6510 and it will only run RL 8.x because 9.x requires later hardware due to a later version of Linux core I believe.
I looked up Lenovo ThinkPad W540 and see a review published 14 August 2014 so it seems to be an older laptop as well.
A possible solution would be to try RL 8.
Hope this helps.

I don’t think so. I have a W540 running Fedora 38 currently. Fedora38 uses a much newer kernel (6.5.10-200.fc38.x86_64) than RL 9.3

The hardware limitation for RHEL9 has nothing to do with the kernel version and has all to do with the kernels compiled specifically for the RHEL9 release. The Fedora kernels are not compiled with those limitations.
Release note RL9
But, because you got as far as you did in the install I don’t think it is the issue. The installer will exit before the install begins. You are beyond that.

You refer to the fact that core RL9 components are built to require CPU instructions that are listed by x86_64_v2.
Intel has made such CPU’s since 2009 and AMD since 2014.
On RL8 (and Fedora 38) one can run --help to see what CPU does support.

Anyway, the RL9 installer’s kernel would crash way before the stage that the output in OP screenshot has (if CPU were not enough).

Thanks for letting me / us know about --help.
I am just a retired home user of RL and not a computer expert at all, so this is --help-full :slight_smile:
I have often learned from your many posts on this forum (and I think I have seen you on other forums as well) - thanks for being such a great contributor :slight_smile:

Thanks for letting me know. I am just a home user of RL and not a computer expert.

Thanks to everybody for your interest and answers; now I’m one step ahead due to:

  • sspencerwire suggestion, so I enabled security chip in bios (no TPM, too modern for my laptop…)
  • also if under discussion, as suggester by RL1000 I’m trying only RL v8.8
    and the crash looks better now and just one page… :grimacing:
    I’ll stay tuned for any other tip, thank you!

Hmm… that rather looks to me as if there’s an issue loading the GUI.
Are you able to boot into single-user mode?

So what’s up with the “target encrypted volumes”?

That line is from just like the previous line is from
Both targets are described in man systemd.special
The Local Encrypted Volumes target was reached, so it is not the problem. If there are no encrypted
volumes, then the target does not even need to do anything.

As usual, the telling errors, the first real failure are not at the end of output.
Were the “ACPI” the first errors?
(I’ve never understood ACPI, but some kernel command-line options might help with it.)

Thanks jlehtone for the explanation.
Back to the OP’s issues, they need to be able access the physical logs so they can copy and paste the relevant errors into a google search. The last ten lines printed to screen may not be the key piece. Any live cd should allow you to mount the unencrypted root partition and find /var/log/dmesg or some other legacy log that is not absorbed into the journal. Can you use journalctl to view other OS journals?

The default for systemd journald is to write only to /run/, to RAM. That is gone after shutdown.
It is possible to enable “store journal to disk”, but that does not help OP now.
man journalctl does mention options --directory and --file, so a “yes”?

The Rocky install image does have “troubleshoot/rescue” option (in addition to install), so an additional Live is not needed (if the install image has not been erased).

Using the “Install RL 8.8 in basic graphic mode” option I was able to bypass the ACPI errors you have seen in the previous posts and finally install it, but the errors are still there and during and after installation the graphical UI is huge, larger than my display and very tough to navigate, and after reboot I cannot change the display resolution because the display setting says it is an unknown type;
anaconda.log says: DBG ui.gui: Detected primary monitor: 640x480 96dpix 96dpiy
How can I change it?
Below you may find the command line info about my two GPUs…may be this the problem, two GPUs?
[maux57@localhost logs]$ sudo lshw -C display
[sudo] password for maux57:
description: VGA compatible controller
product: GK107GLM [Quadro K1100M]
vendor: NVIDIA Corporation
physical id: 0
bus info: pci@0000:01:00.0
version: a1
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress vga_controller bus_master cap_list rom
configuration: driver=nouveau latency=0
resources: irq:30 memory:b0000000-b0ffffff memory:80000000-8fffffff memory:90000000-91ffffff ioport:4000(size=128) memory:b1000000-b107ffff
description: VGA compatible controller
product: 4th Gen Core Processor Integrated Graphics Controller
vendor: Intel Corporation
physical id: 2
bus info: pci@0000:00:02.0
version: 06
width: 64 bits
clock: 33MHz
capabilities: msi pm vga_controller bus_master cap_list rom
configuration: driver=i915 latency=0
resources: irq:31 memory:b1400000-b17fffff memory:a0000000-afffffff ioport:5000(size=64)
Would like to upload here also the tar file with all the contents of /tmp dir just after installation, hoping some expert can read the logs and discover what is wrong with my lenovo thinkpad W540, but just discovered only images can be uploaded.
Thank you

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.