Changing strictly unmanged network connection to managed

This is my first install of 9 and it set up the network on DHCP which worked fine, then I installed webmin and changed the network interface to static IP. After a reboot the network was not up I tried nmtui and it would not activate.

Connection ens192 is not available because device is strictly managed is there an easy way that I can set it to be managed or do I have to reinstall everything. This is not a big problem now, but I would be terrified that this could occur on a live system and that I simply could not connect to the network.

How did you change the IP address settings? In Webmin? In Network Manager? This would be good to know so that people can help and also explain what went wrong. I’m guessing changed in Webmin, since normally changing from DHCP to static IP in Network Manager works every time.

Better for managing the server is to use Cockpit instead of Webmin. It exists in the Rocky repositories and can be installed using dnf.

I did it using Webmin then rebooted. I tend to use virtualmin which is based on webmin, so this was partially a test of that. But understanding how the networking works is very important to me and this is not easy. I will check out cockpit on a fresh install. This is installed on vmware esxi 7

I’m pretty sure that the problem here is webmin/virtualmin. I expect if you created a new machine that was getting an IP from dhcp, and then you login to it, and use nm-tui instead from the console, or nm cli commands, that if you change and configure it for a static IP with either of those Network Manager options is that it will just work.

The problem here most likely is webmin/virtualmin did something completely different, eg: incompatible with Network Manager and screwed it all up.

In theory webmin/virtualmin, nice idea, but in reality not all that helpful - I guess maybe for some people - I just found it far too problematic. Better is to learn the distro-specific configuration options than some third-party web management tool that can have a tendency to bork things, not just network, but also configuration files as well for various other services or whatever you attempt to manage with it.