Can't ssh into my server

Good evening.

I am experiencing a funny error on ssh-ing to my Server. The error I get is this:

08:49:48 jil@rocky-linux-9 ~ → ssh jil@
/etc/ssh/ssh_config line 56: no argument after keyword “\200kd\200kd\200kd\200kd\200kd\200kd\200kd\200kd\200kd\200kd\200kd\200kd\200kd\200kd\200kd\200ku\200ku\200ku\200kd\200kd\200kd\200kdi\200kd\200kd\200kd\200kd\200kd\200kd\200ku\200ku\200ku\200ku\200ku\200ku\200ku\200ku\200ku\200ku\200ku\200ku\200ku\200ku\200ku\200ku\200ku\200ku\033\200\375a:q”
/etc/ssh/ssh_config: terminating, 1 bad configuration options

When I check the said file, this is what I see.
sudo vim /etc/ssh/ssh_config
Include /etc/ssh/ssh_config.d/*.conf
“/etc/ssh/ssh_config” [converted] 56L, 2117B 56,1 Bot

What is this supposed to mean? Please help.

Can you try:

rpm --verify openssh-clients

but also clarify, there are two computers, one that you’re connecting from, and one that you’re connecting to?

The ssh_config is in the machine where you run the client and regular user can read the file with cat /etc/ssh/ssh_config or less /etc/ssh/ssh_config (with less being safer since it warns if file has binary content). No need to ‘sudo’ nor vim.

The “Include…” ought to be the last line and there should be comments before it. Your file looks corrupted (and the rpm --verify openssh-clients should tell that too). Did you edit it at some point? You shouldn’t, for you can create new files in directory /etc/ssh/ssh_config.d/ that have extension .conf and the Include statement will then use them.

I would check whether I can run sudo dnf reinstall openssh-clients. If I can, then I’d remove the /etc/ssh/ssh_config and run sudo dnf reinstall openssh-clients one more time.

Still, what did corrupt the file? What else has been corrupted?

1 Like


This worked for me. after reinstalling the openssh-clients, I am now okay.
Thanks, man, truly appreciate it.

Hello @gerry666uk

The command rpm --verify openssh-clients did not give any output.
I have one physical computer and a VM.
the command sudo dnf reinstall openssh-clients worked it fine. I can now ssh to my VM.
Thank you sir.