Any Way to Get a 24 Hour Digital Clock On Rocky Linux 8.6? [SOLVED]

Well I continue to configure aznd polish RL 8.6 on the 1 TB MP 600 NVMe 4th Gen Drive.

Yesterday I noticed that my Digital Clock was in 12 hour AM / PM output . At some point I noticed that the time was WAY OFF. So I tried to reset it. So I changed the battery (which holds Date and Time among other things) . Only now I discovered I was supposedly located in Zurich Swiss!!! I was no longer in Arizona!!. I tried to run dnf update, only NOW it refused to up date my machine. Trying to “FIX” the problem via icon from the “Application Launcher” was a NoGo. Next I went hunting for a CL command… and found one… at least sort of in that it got me “back” to Arizonaz.

The first thing you have to do is turn OFF Chronyd [ systemctl stop chronyd ]

The NEXT command is one you should bookmark or remember is timedatectl set-time [ enter-the-time; enter the date; or enter ‘date and time’ for both Example ‘2021-10-11 12:15:25’ ]

Finally there is timedatectl list-timezones followed by timedatectl set-timezone
Example: timedatectl set-timezone America/Phoenix

While this finally straightened out the time and location problem the time is still printed out such as 3:42 AM – vs – 03:42:26. Does anyone know how to switch from the 12 hour AM / PM format in Rocky Linux to the 24 Hour Format?? This was how I got into trouble. There does not seem to be a 24 hour format selection in Rocky Linux 8.6 – or at least one I could find

I would say “Settings”, “Time & Date”, “Time Format” that has both “12-hour” and “24-hour” options.
Alas, that is in Gnome 40 of EL9. I have no recollection of what options Gnome 3 of EL8 had.

There is no reason to stop chronyd. It does tune the time quite quickly (unlike ntpd – ntp service did call ‘ntpdate’ first to oneshot time about right before starting the ntpd).
The timedatectl set-timezone America/Phoenix was what you had to do.

You do have a question now though: what did change you timezone setting (and output format)?

1 Like

I second what @jlehtone says. Assuming when you say:

that you mean in the graphical environment, then you will configure it in the Gnome settings, or KDE settings, or whatever desktop you use. This should exist for Gnome 3 as well as 4. The console is a different matter, which requires using localectl. I’ve no idea why en_US or by configuring a US timezone seems to default to AM/PM instead of 24 hour. I guess there is a reason for it.

Unless you need to configure it on the console, none of the timedatectl, localectl commands need to be used, the rest can be done in the GUI configuration tools.

“Unless you need to configure it on the console, none of the timedatectl, localectl commands need to be used, the rest can be done in the GUI configuration tools.”

The GUI configuration Tools did not work – trust me that was where I tried FIRST and the way I have done it for 22+ years. Indeed I suspect that something in some aspect of the GUI config tools was what was broken which is probably how I ended up in Zurich, Swiss. just by setting the time. This could also be a KDE 5 problem. The ONLY way I was able to PARTIALLY SOLVE the problem was to resort to the Konsole – at least doing that I was able to get back to Arizona, as well as set the correct 12 hour time.

After I solve a problem in CentOS 7.9 where I get the following message: " Error: Invalid version flag: or ".
“or” what ? Until I SOLVE THAT PROBLEM my machine REFUSES to update. I suspect this may have something to do with SkypeforLinux , which suddenly went out into the weeds. Then again Skype may have been a victim of what ever caused the : " Error: Invalid version flag: or " to appear. I swear my apartment must be filled with Gremlins. Errors I have NEVER seen before have suddenly appeared by the boatload.

After I deal with the above problem as leopard is still my current WS, then I may shut down RL 8.6 / KDE5 and bring it up in RL 8.6 / GNOME and at least PEEK to see if I could possibly set the 24 hour clock from there.

“Something Wicked this way comes.”

D’ Cat

P.S. Does anyone have an anti-Gremlin spell I can cast to get rid of these Gremlins?

jlehtone

Blockquote

I would say “Settings”, “Time & Date”, “Time Format” that has both “12-hour” and “24-hour” options.
Alas, that is in Gnome 40 of EL9. I have no recollection of what options Gnome 3 of EL8 had.

Blockquote

Yep went there too. Only 12 hour format found. Now this may sound strange, but GNOME – or any of its decendents – does not have a Digital Clock by default, though a “Time” does appear in the dead upper center. Clicking on it does zero.

As to what I did… Good question. I might of accidentally hit something with my rather shaky hands that hijacked me to Zurich, Swiss.

This remains a problem I need to research. For the time being I guess I can live with a 12 hour clock – at least I am in the right Country, Right State, and have the right Time. Still I use to using a 24 hour military clock (though hard to believe that was 52 years ago) – Some things simply graft themselves onto your mind if you used them every day. I THINK in a 24 hour clock cycle, a 12 hour clock is simply something that needs to be converted.

Mark this [SOLVED]!!!

  1. RIGHT CLICK on the Digital Clock on the Panel

  2. Find * CONFIGURE DIGITAL CLOCK* and LEFT CLICK on this.

  3. Find TIME DISPLAY This is marked USE REGION DEFAULTS to the Right of this is a DOWN ARROW Now CLICK ON THE DOWN ARROW This will give you a Drop Down Menu.

  4. One Part of the Drop Down Menu says " 12-HOUR "; the other entry says “24-HOUR”. Select 24-HOUR Now at the BOTTOM of the MENU you will see APPLY with a Check Mark next to it. Click On APPLY and it will Gray out.

  5. Next to the Apply Box, there is another Box marked OK with a Check Mark next to it. Click On OK. Now the DIGITAL CLOCK on the PANEL will now be in 24 HOUR units.

  6. If you wish to show the time with Seconds, go back to the DIGITAL CLOCK on the PANEL and
    RIGHT CLICK on it. You will get the familiar “CONFIGURE DIGITAL CLOCK SETTINGS” Drop Down Menu. There are some blocks, some EMPTY one of which says * SHOW SECONDS* , now CLICK ON THE EMPTY SHOW SECONDS BOX and a CHECK MARK will now fill the Empty Show Seconds Box. Now go back and CLICK ON the A) APPLY and be B) OK boxes and now the seconds will be added to your time.

  7. Finally if this FAILS, there is a box that says, " CHANGE REGIONAL SETTINGS " amd that might free up the box that is marked “USE REGION DEFAULTS”

That’s It!! Mark this [SOLVED]!!


*BTW This works in KDE PLASMA 5.23.3


Hi @desercat

first: Good to see you back. :wink:

Now, some parts of this thread are not clear to me. What Desktop Environment are you running? I’m on RL 8.6 with Gnome (the upgraded-since-RL-8.5 whatever version it is now) and my “upper center time” isn’t dead at all: The calendar / notifications panel appears when I click on it. Gnome default behavour so to say.

And from what have seen since the mid-80s (not kidding, I’m old) any location that is in the US defaults to regional settings of decimal-point instead of comma, Imperial not Metric system, Fahrenheit not Celsius temperature and first of all: 12hr “AM/PM” time format instead of the so-called “military” 24hr format.
Anyway, yes I know it’s fixed for you, but looking at the fiddling it took you to get things going your way, I was wondering what could be “wrong” with your setup. Are you using any exotic gnome extensions? Did you “hack” settings somewhere using stuff like dconf-editor?

BTW: I’m having “topicons” sitting in the center (right next to the center time) so there’s ways to do more in the center area of gnome’s top panel.

Cheers, Thomas

Good to see you too.
No. I am running KDE Plasma 5.23.3. I am truly not too familiar with GNOME – more a backup DE in case KDE goes out into the weeds.

No I am not quite as old as you – turned 70 in April. I served in the Army during Viet Nam, and ran a switchboard ergo the 24 hour clock. We ran 24/7/365 and we had to be ready for transport at xyz time, and I alway cought graveyard shift. None of this AM / PM stuff. We actually had a 24 hour clock in the switchboard room we referred to. I have continued to THINK in that way. Likewise as an EX-Research Scientist I use both Metric and Imperial . As to temperature I still use F degrees – when it is 110 in AZ it is HOT!!!

As to my [SOLVE], at lot of my memory right now is like Swiss Cheese as well as eyesight wherein I see double. The Eye doctor refuses to prescribe a new set of glasses as my vision is changing that FAST – he says that it will be 3-6 MONTHS before it stahblizes. If I want to read I cover one eye with a patch – ARGG Matey.

Best Fishes,
D’ Cat

1 Like