Anaconda install/startup or deletion of installed

New rocky8 user. It appears a version of anaconda (the python organizer) was installed during the system install. I did not request it. On other distros, I have installed anaconda often but as a user and created environments as a user. There was no root portions of an anaconda install. All was owned by the user.

I see internet references to fedora, centos, redhat as having what’s called “linux anaconda” which, I guess, means a system anaconda. I need some instructions on how to use this. I can’t find any. All my tries at creating a conda environment as a user were unsucessful as user did not have proper permissions (needed root). I don’t want to create environments as root or run python things as root. I have other systems where that is not necessary. In fact the active anaconda environment becomes part of the user ommand prompt. Help please.

If I can’t get the installed anaconda into some user managed mode, I will try to uninstall the entire package and reinstall anaconda as a user and run it as a user. Will need some instructions for a complete removal.

Any help with this issue, please?

tom kosvic

Is this the information you need?

RHEL (and hence Rocky) uses the “Anaconda (installer)” for installing the OS into computer. RHEL does not have the “Anaconda/Miniconda/Conda (Python distribution/Python package manager)”.

EPEL repository provides the latter. You can get it with:

sudo dnf install epel-release
sudo dnf install conda

From the above responses, I think I didn’t make my query clear. During installation of rocky8, anaconda (python) was automatically installed into root directories. I did not knowlingly request its installation. This default installlation includes conda (anaconda package manager) and, I think, the python files included with a base anaconda setup.

To use anaconda, you need to set up environments using conda. When a user (not root) runs conda in my rocky8, as installed in root, and tries to set up an environment, the “conda create -n XXXX” function does not work because user does not have the right permissions as all the code is owned by root. I do not wish, and should not have to run conda as root.

My question is: how to use the root installed anaconda that was installed by rocky8 installation software as a user? On all the other distros I have running, anaconda is installed in /home/user directory and a user has full control. There are no root installed pieces.

I am thinking about changing the permissions on the system installed anaconda so user has more access.

Is anyone running the system root installed anaconda as a user and how?

thanks, tom kosvic

The name of the program that initially installs rocky8 is “anaconda”. Yes, the default install probably includes package anaconda. These have nothing to do with python, or your “anaconda”.

Yes, rocky8 has python. The package manager dnf (and some other system management tools) are Python-based applications. The “platform-python” is obligatory component. However, “python for user” is not. That has to be installed separately. There are more than one version of python for users available and application streams. The python36 uses the “platform-python”.

Rocky does not have “conda”, AFAIK. Please show output of:

which conda
rpm -qif $(which conda)

I have installed conda on CentOS Linux 7 system (also from EPEL) and in there regular user can use it “just fine”.

I removed all the root references to anaconda. There was a conda app in a root directory. I had no idea that the installer was also called anaconda. Running the system installed conda was the one that wouldn’t allow creation of an environment as a user. If I now do “which conda” it now shows the conda in my home/user/anaconda3 directory. I believe the system installed conda was conda.noarch from the epel repo. Again, that is no longer there.

Problem solved. I installed full new anaonda as user and all went well. I have several environments now installed. I think my issues is over. The root installed anaconda looked to me like a python anaconda as there were many python files.

I hope that deleting the installation manager anaconda didn’t harm anything but it is all gone except for some doc files and man files. If there’s something I should know about, let me know.

thanks, tom kosvic

One other point, I forgot to mention. When the install anaconda was within root (before I deleted it), when I tried to install a new anaconda as a user, the prefix it wanted to install into was /usr.

After the install anaconda was deleted, the anaconda installer wanted to install to /home/user/anadonda3; not /usr. So, it looks to me that the anaconda installer thought that the other anaconda was python anaconda.

However, now all is fixed. Root anaconda is gone. I think the rocky 8 installer should get a name change from anaconda.

tom kosvic

Rocky’s installer is same as RHEL’s installer. That installer was initially released in 1999, way before the first version of RHEL. I can’t say whether the early versions of RHEL did use that, or something else, but Anaconda is an old beast.

The Python distribution that is not bound to any particular OS, the “Anaconda”, was first released 2012. Why did they take that name?

That’s far from the only example of a johnny-come-lately horning in on a perfectly good name that’s already in use.

The one that bugs me most (because I use it) is xforms.

xforms is a gui toolkit, dammit! Anyone who thinks xforms has anything to do with xml processing is obviously lying. :slight_smile:

(That’s my off-topic rant for today. I’m feeling much better now…)