After update, screen is blank out in rocky 9.2

After I reboot the server, it installed updates and after the screen is blanked out. How to disable the auto update? and what do I need to change for blank screen?

Rocky Linux does not automatically install updates. Installing packages or installing updates requires a user’s input or a user configuring the system to update automatically.

Performing an update would bring you to Rocky Linux 9.3. 9.2 is no longer in support and you are recommended to update your systems.

Thanks. Is the blank screen has anything to do with the tigervnc server that is running? when I stop the tigrevnc, then I get back the screen by using ctl-alt-f2

If you are actually on 9.3, there is an RHEL bug also present in Rocky 9.3 that is not publically viewable which affects people using some variants of the Matrox MGA G200 video chip. I have a patch for it, which has been approved by RedHat and will be incorporated in 9.4 when it comes out. You can tell whether you have that chip by doing either of

lspci | grep Matrox
lspci | grep VGA

and if you get nothing listed then you haven’t got it; if you get a response saying which variant you’ve got then let me know. Message me on here if you have got it and want the patch.

One should give option -nn to lspci (lspci -nn) because that adds device ID to the output and the ID is as exact description of the variant as possible.

I got reply : Matrox Electronics systemltd. MGa G200eH3
and VGA compatible controller: Matrox electronics system ltd.

What I noticed is that the blank display has something to do with TigerVNC server.
If I stop the tigervnc server, I get back the display.

the lspci | grep … shows that I have the chip. May I get the patch to try please

So, the particular chip variant you describe (the eh3 variant) is NOT one of those that would be fixed by the patch I have (which only affects the se, er, and ev variants).

However, it is still quite possible that the culprit is in the kernel module driving the mgag200 chip, IF you are indeed using rocky 9.3, because this was completely rewritten between 9.2 and 9.3; indeed it also underwent a complete rewrite going up to 9.2 if I remember right, and there were also problems for my variant (the se variant) with that.

Your options for investigating any effect of this particular kernel module rewrite seem to me to be as follows:

  1. Report this as a bug to RedHat, and specifically suggest that it may be to do with the mgag200 module. Somebody will deal with it - when you get to be dealing with Jocelyn you will know that you have the right expert.

  2. I would be happy to help look into this if you want, as I have some time this week (but much less in the six weeks following). If so, the first thing you need to do is to send me the complete outputs of

uname -a
lspci -nn | grep Matrox
lsmod | grep mgag
modinfo mgag200

Moreover if you do want to take option 2 then it would be far more convenient for me to deal with you by direct email than via the forums; if so please send me your email address to roger.sewell at cantab.net (obviously substituting the symbol for at).

Roger.

Rocky may not auto-update by default but my 9.3 installation does.
I have not intentionally configured this and have not knowingly installed dnf-auto and I do not have a /etc/dnf directory.
What else could cause auto-update?

It’s possible that you may also want to stop, disable, and mask the following (using systemctl):

packagekit.service
packagekit-offline-update.service
dnf-makecache.timer

I did that and it appeared to stop auto-updating. If you want the cache to be updated without the new packages being installed you might leave dnf-makecache.timer running.

Roger.

But, in a default Rocky 9.x install, ‘dnf-makecache.timer’ would be running, ‘packagekit.service’ would be enabled, and ‘packagekit-offline-update.service’ would be inactive. There’s a big difference between being notified about available updates and “auto-update”.

1 Like

I am still seeing “automatic” updates.
I do NOT have dnf-auto* installed. systemctl status for any dnf-auto* returns “not found”.
What I do see is a notification that updates are available and then, when I restart my box, it installs stuff.
Today it was Firefox, Thunderbird and kernel.
Having been bitten by auto updates in the past, I really want to turn it off but can’t see how.

Can you check again? You should have it.
Try also
rpm -q dnf-data
this is the package that provides the directory

You have clarified that you are seeing the usual notification about updates being available, but that somehow when you restart your box it installs stuff.

This isn’t normal on a clean install of Rocky 9.3, so have you installed anything that is not from the official Rocky 9.3 repos?

In addition, how do you know updates are being applied after reboot? In the case of the kernel, did you know the exact old version, and then suddenly noticed it was different in the grub menu? How did you know Firefox had been updated, did it show the update page with a new version, and you knew the old version?

My mistake. I do have /etc/dnf and rpm -q dnf-data returns a valid path.
I know that updates have been done because it tells me.
In a similar way that “updates are available” pops up, “Updates are being installed” pops up after booting.
The only extra that I have installed is Google Chrome but I have discovered (the hard way) that unexpected stuff like fapolicyd was installed and activated as part of my initial supposedly simple workstation install.

OK, good news you found /etc/dnf, so you should be able to find dnf logs under /var/log and see exact details of any updates done by dnf including exact package names and exact dates and times.

Regarding the popup saying “Updates are being installed”, I start to wonder if you enabled this via “Gnome Software”, I see it has an update feature. I only use dnf.

Regarding Google Chrome, I don’t think it’s in the official repos and therefore not supported, could actually be dangerous, are you sure it’s 100% open source?

Regarding ‘fapolicyd’ I don’t see how it could get on there with a standard workstaion install. It’s not installed here.

I’m on 9.2 and went to 9.3, same issue… after a while when it idles, the UI goes BOOOOOOM…

I’ve tried many different installation approaches on VMs and baremetal… this is extremely frustrating as I spent weeks customizing a VM for backend systems.

Just to clarify here… @ HaNas2001 and TwoXTwentyOne : is this issue only occurring on 9.3 systems with a GUI installed (GNOME?), or is it even happening with just a minimal, console/text-only installation?

Thanks!

lg97