# ZFS SMB share problem

**URL:** <https://forums.rockylinux.org/t/zfs-smb-share-problem/4539>\
**Category:** Rocky Linux Help & Support\
**Created:** [November 12, 2021, 4:18pm UTC](https://forums.rockylinux.org/t/zfs-smb-share-problem/4539 "2021-11-12T16:18:03Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![drlinux](https://sea2.discourse-cdn.com/flex020/user_avatar/forums.rockylinux.org/drlinux/32/1380_2.png) [@drlinux](https://forums.rockylinux.org/u/drlinux)\
**Post date:** [November 12, 2021, 4:18pm UTC](https://forums.rockylinux.org/t/zfs-smb-share-problem/4539/1 "2021-11-12T16:18:03Z")

</div>

Hi folks,

I just simply trying to create a zpool and share it via samba. You can see the steps that I follow and the error.

```auto
zpool create -f -m /mnt/data mypool /dev/sdb
zfs set sharesmb=on mypool
cannot share 'mypool: system error': SMB share creation failed

```

Samba service is up and running. I have created a share in my ubuntu server with the same commands successfully. Could you please give me any advice?

```auto
zfs-2.0.6-1
zfs-kmod-2.0.6-1
4.18.0-305.25.1.el8_4.x86_64

```

---

<div class="post-metadata">

**Author:** ![iwalker](https://sea2.discourse-cdn.com/flex020/user_avatar/forums.rockylinux.org/iwalker/32/2599_2.png) [@iwalker](https://forums.rockylinux.org/u/iwalker)\
**Post date:** [November 12, 2021, 5:26pm UTC](https://forums.rockylinux.org/t/zfs-smb-share-problem/4539/2 "2021-11-12T17:26:11Z")

</div>

Most likely an selinux thing, you can check /var/log/audit/ log files. Also you can do:

```auto
setenforce 0

```

to set selinux in permissive mode, and then redo the commands to see if it creates. That would confirm an issue with selinux at least.

---

<div class="post-metadata">

**Author:** ![drlinux](https://sea2.discourse-cdn.com/flex020/user_avatar/forums.rockylinux.org/drlinux/32/1380_2.png) [@drlinux](https://forums.rockylinux.org/u/drlinux)\
**Post date:** [November 13, 2021, 3:59pm UTC](https://forums.rockylinux.org/t/zfs-smb-share-problem/4539/3 "2021-11-13T15:59:07Z")

</div>

SELinux status is disabled but still having the same problem. SELinux completely disabled, server rebooted, zpool destroyed and created again.

---

<div class="post-metadata">

**Author:** ![robshinn](https://sea2.discourse-cdn.com/flex020/user_avatar/forums.rockylinux.org/robshinn/32/3339_2.png) [@robshinn](https://forums.rockylinux.org/u/robshinn)\
**Post date:** [July 12, 2023, 5:39pm UTC](https://forums.rockylinux.org/t/zfs-smb-share-problem/4539/4 "2023-07-12T17:39:55Z")

</div>

I realize this thread is over 2 years old, but as it comes up as a top search result for `cannot share 'mypool: system error': SMB share creation failed`, I’m going to put what worked for me: you are missing the `samba-usershares` package. This is required to use zfs Samba integration.
