Vpnc option missing for VPN network

vpnc option is missing in the VPN network. I’ve tried many things including reinstall the OS with packages that I thought would add the options for the VPN network. So far no vpnc option can be found. Can some on please help?

Hi,

Try:

sudo dnf install NetworkManager-vpnc

Then under Settings, Network. Click the plus for the VPN section. Cisco Compatible VPN (vpnc), should be an option.

Thanks Tom.

Sorry ignore the above, thats for fedora. Doesn’t look like vpnc is in epel for centos 8. Are you using a desktop environment? Is this for cisco any connect? This may help:

Thanks Tom.

Yes, I’m runing gnome. No…not cisco anyconnection…yes cisco client connect.

BTW, I’ve tried Cisco AnyConnect. It’s not compatible.

Hi,

google search found this:

Which suggests libreswan may work:

sudo dnf install NetworkManager-libreswan-gnome

Thanks Tom.

I’ve tried that site already.
#dnf install vpnc network-manager-vpnc-gnome

No match for argument: vpnc & network-manager-vpnc-gnome

Just tried

dnf install NetworkManager-libreswan-gnome

The package is installed but no vpnc option show up on the network settings

Hi,

No its not vpnc, its compatible. After install should have one (if not both options):

From reading the link from reddit for vpnc, I belive either openconnect or ipsec, should work.

Thanks Tom.

2 Likes

Yes, @tjdoyle has it right. I use the openconnect to connect to Cisco anyconnect - works fine, at least in the distro I use on my laptop, haven’t tried it with Rocky yet.

1 Like

I’ve tried to roll my own with Fedora 33 for NetworkManager-vpnc-gnome-1.2.6-5.fc33.x86_64.rpm. Solving the dependency is tricky. I might have mess up the installation. I need a fresh start to try again.

I’ve succeeded to install the vpnc option on the VPN network
Screenshot from 2021-07-07 22-51-21
These rpm packages are what I’ve used…
NetworkManager-vpnc-1.2.6-5.fc33.x86_64.rpm
NetworkManager-vpnc-gnome-1.2.6-5.fc33.x86_64.rpm
vpnc-0.5.3r550-lp150.1.10.x86_64.rpm
libgcrypt-1.8.5-5.el8.x86_64.rpm
Go to “rpmfind.net” to download them. They’re based on the Fedora 33 release.
Reboot is required to complete the setup

1 Like