# Tac\_plus\[320973\]: Error get\_socket: bind 49 Address already in use

**URL:** <https://forums.rockylinux.org/t/tac-plus-320973-error-get-socket-bind-49-address-already-in-use/16469>\
**Category:** Rocky Linux Help & Support\
**Created:** [November 12, 2024, 3:20pm UTC](https://forums.rockylinux.org/t/tac-plus-320973-error-get-socket-bind-49-address-already-in-use/16469 "2024-11-12T15:20:42Z")\
**Posts on this page:** 14\
**Page:** 1

<div class="post-metadata">

**Author:** ![Akshay](https://avatars.discourse-cdn.com/v4/letter/a/3ab097/32.png) [@Akshay](https://forums.rockylinux.org/u/Akshay)\
**Post date:** [November 12, 2024, 3:20pm UTC](https://forums.rockylinux.org/t/tac-plus-320973-error-get-socket-bind-49-address-already-in-use/16469/1 "2024-11-12T15:20:42Z")

</div>

![image](https://us1.discourse-cdn.com/flex020/uploads/rockylinux/original/2X/1/1c615f012aab23a8b0b8ec434c15ce02b1839395.png)

Unable to start the tacacs+ plus service, please see the error attached.

---

<div class="post-metadata">

**Author:** ![gerry666uk](https://avatars.discourse-cdn.com/v4/letter/g/dbc845/32.png) [@gerry666uk](https://forums.rockylinux.org/u/gerry666uk)\
**Post date:** [November 12, 2024, 7:46pm UTC](https://forums.rockylinux.org/t/tac-plus-320973-error-get-socket-bind-49-address-already-in-use/16469/2 "2024-11-12T19:46:30Z")

</div>

The list of listeners says you’ve already got something on port 49.

---

<div class="post-metadata">

**Author:** ![rwolfe716](https://avatars.discourse-cdn.com/v4/letter/r/9dc877/32.png) [@rwolfe716](https://forums.rockylinux.org/u/rwolfe716)\
**Post date:** [November 13, 2024, 12:41am UTC](https://forums.rockylinux.org/t/tac-plus-320973-error-get-socket-bind-49-address-already-in-use/16469/3 "2024-11-13T00:41:52Z")

</div>

tried telnetting into port 49 on this machine to see if a banner appears? "if so, that might give you dome idea as to what is listening on that port a ps -ef | grep root might also help…

---

<div class="post-metadata">

**Author:** ![Akshay](https://avatars.discourse-cdn.com/v4/letter/a/3ab097/32.png) [@Akshay](https://forums.rockylinux.org/u/Akshay)\
**Post date:** [November 13, 2024, 7:12am UTC](https://forums.rockylinux.org/t/tac-plus-320973-error-get-socket-bind-49-address-already-in-use/16469/4 "2024-11-13T07:12:08Z")

</div>

![image](https://us1.discourse-cdn.com/flex020/uploads/rockylinux/original/2X/9/9a7a752f69fae7f00add75fe21509f41697b1d81.png)

Looks like port 49 is being used by the tac\_plus service

---

<div class="post-metadata">

**Author:** ![gerry666uk](https://avatars.discourse-cdn.com/v4/letter/g/dbc845/32.png) [@gerry666uk](https://forums.rockylinux.org/u/gerry666uk)\
**Post date:** [November 13, 2024, 9:05pm UTC](https://forums.rockylinux.org/t/tac-plus-320973-error-get-socket-bind-49-address-already-in-use/16469/5 "2024-11-13T21:05:09Z")

</div>

So it sounds like Tac\_plus is already running, and you’re trying to start it a second time? Might be worth testing from cold boot.

---

<div class="post-metadata">

**Author:** ![Akshay](https://avatars.discourse-cdn.com/v4/letter/a/3ab097/32.png) [@Akshay](https://forums.rockylinux.org/u/Akshay)\
**Post date:** [November 14, 2024, 7:25am UTC](https://forums.rockylinux.org/t/tac-plus-320973-error-get-socket-bind-49-address-already-in-use/16469/6 "2024-11-14T07:25:14Z")

</div>

The service stops immediately when I start it.

---

<div class="post-metadata">

**Author:** ![jlehtone](https://avatars.discourse-cdn.com/v4/letter/j/e9a140/32.png) [@jlehtone](https://forums.rockylinux.org/u/jlehtone)\
**Post date:** [November 14, 2024, 8:43am UTC](https://forums.rockylinux.org/t/tac-plus-320973-error-get-socket-bind-49-address-already-in-use/16469/7 "2024-11-14T08:43:11Z")

</div>

That was not the “question”. The service stops because it fails to start tac\_plus. The tac\_plus fails to start, if there is already a tac\_plus running. A process that was not started by service unit.

```bash
pgrep -a plus
ss -tulpn | grep ":49"

```

Does the first show a “tac\_plus” process?  
Does the latter show the process that listens on 49?

* * *

PS. One can usually copy-paste text from terminal to forum posts and format with code tags. The result is more convenient than screenshots.

---

<div class="post-metadata">

**Author:** ![Akshay](https://avatars.discourse-cdn.com/v4/letter/a/3ab097/32.png) [@Akshay](https://forums.rockylinux.org/u/Akshay)\
**Post date:** [November 18, 2024, 12:25pm UTC](https://forums.rockylinux.org/t/tac-plus-320973-error-get-socket-bind-49-address-already-in-use/16469/8 "2024-11-18T12:25:51Z")

</div>

pgrep -a plus  
ss -tulpn | grep “:49”  
15241 tac\_plus -C /etc/tac\_plus.conf  
tcp LISTEN 0 4096 0.0.0.0:49 0.0.0.0:\*

yes, I do not see the process that listens on 49

---

<div class="post-metadata">

**Author:** ![jlehtone](https://avatars.discourse-cdn.com/v4/letter/j/e9a140/32.png) [@jlehtone](https://forums.rockylinux.org/u/jlehtone)\
**Post date:** [November 18, 2024, 12:51pm UTC](https://forums.rockylinux.org/t/tac-plus-320973-error-get-socket-bind-49-address-already-in-use/16469/9 "2024-11-18T12:51:33Z")

</div>

> [@Akshay](#):
>
> ```auto
> ss -tulpn | grep ":49"
> tcp LISTEN 0 4096 0.0.0.0:49 0.0.0.0:*
> 
> ```
> 
> yes, I do not see the process that listens on 49

Regular user does not see the name. The root does:

```auto
me:1:~$ ss -tulpn | grep ":22"
tcp LISTEN 0 128 0.0.0.0:22 0.0.0.0:*          
me:1:~$ sudo ss -tulpn | grep ":22"
tcp LISTEN 0 128 0.0.0.0:22 0.0.0.0:* users:(("sshd",pid=981,fd=3))  

```

However, even as regular user you do see that something on your machine does listen `tcp/49` at `0.0.0.0`.

* * *

> [@Akshay](#):
>
> ```auto
> pgrep -a plus
> 15241 tac_plus -C /etc/tac_plus.conf
> 
> ```

Yes, you do have process ID `15241` – a `tac_plus` running. It’s existence blocks the service from starting.

You could simply kill that process, but what might have started it? You could look at process listing first:

```bash
ps axfu | grep -B6 -A2 tac_plu[s]

```

Thing is, if some “service” started it, then it might run also on next boot and again block your _intended service_.

---

<div class="post-metadata">

**Author:** ![Akshay](https://avatars.discourse-cdn.com/v4/letter/a/3ab097/32.png) [@Akshay](https://forums.rockylinux.org/u/Akshay)\
**Post date:** [November 19, 2024, 10:48am UTC](https://forums.rockylinux.org/t/tac-plus-320973-error-get-socket-bind-49-address-already-in-use/16469/10 "2024-11-19T10:48:44Z")

</div>

[@vm~]$ ps axfu | grep -B6 -A2 tac\_plu[s]  
root 1410 0.0 0.0 3044 1920 tty1 Ss+ Oct28 0:00 /sbin/agetty -o -p – \u --noclear - linux  
root 1411 0.0 0.0 3088 1920 ttyS0 Ss+ Oct28 0:00 /sbin/agetty -o -p – \u --keep-baud 115200,57600,38400,9600 - vt220  
root 1611 0.0 0.3 102716 25208 ? Sl Oct28 0:06 /usr/bin/pyth on3 /var/lib/waagent/Microsoft.Azure.Monitor.AzureMonitorLinuxAgent-1.33.0/agent .py -metrics  
root 1613 0.0 0.3 102728 25340 ? Sl Oct28 0:06 /usr/bin/pyth on3 /var/lib/waagent/Microsoft.Azure.Monitor.AzureMonitorLinuxAgent-1.33.0/agent .py -syslogconfig  
zzbeaks+ 15045 0.0 0.1 22916 13908 ? Ss Oct29 0:00 /usr/lib/syst emd/systemd --user  
zzbeaks+ 15046 0.0 0.1 131156 8832 ? S Oct29 0:00 \_ (sd-pam)  
root 15241 0.0 0.0 8268 5224 ? S Oct29 0:03 tac\_plus -C / etc/tac\_plus.conf  
[@vm- ~]$ sudo kill -9 15241

I killed the process and tried to restart the service again

[ro@vm ~]# systemctl restart tac\_plus  
[root@vm ~]# systemctl status tac\_plus  
○ tac\_plus.service - TACACS+ IPv4 Daemon  
Loaded: loaded (/etc/systemd/system/tac\_plus.service; disabled; preset: disabled)  
Active: inactive (dead)

Nov 18 16:39:44 vm systemd[1]: Started TACACS+ IPv4 Daemon.  
Nov 18 16:39:44 vm-2 tac\_plus[435792]: Reading config  
Nov 18 16:39:44 vm tac\_plus[435792]: Version F4.0.4.26 Initialized 1  
Nov 18 16:39:44 vm- tac\_plus[435794]: Received signal 15, shutting down  
Nov 18 16:39:44 vm- systemd[1]: tac\_plus.service: Deactivated successfully.  
Nov 19 10:45:37 vm systemd[1]: Started TACACS+ IPv4 Daemon.  
Nov 19 10:45:37 vm tac\_plus[449997]: Reading config  
Nov 19 10:45:37 vm tac\_plus[449997]: Version F4.0.4.26 Initialized 1  
Nov 19 10:45:37 vm tac\_plus[449999]: Received signal 15, shutting down  
Nov 19 10:45:37 vm- systemd[1]: tac\_plus.service: Deactivated successfully.  
[root@vm- ~]# ps axfu | grep -B6 -A2 tac\_plu[s]  
[root@vm- ~]#  
[root@vm ~]# pgrep -a plus  
ss -tulpn | grep “:49”  
[root@vm- ~]#

---

<div class="post-metadata">

**Author:** ![jlehtone](https://avatars.discourse-cdn.com/v4/letter/j/e9a140/32.png) [@jlehtone](https://forums.rockylinux.org/u/jlehtone)\
**Post date:** [November 19, 2024, 11:14am UTC](https://forums.rockylinux.org/t/tac-plus-320973-error-get-socket-bind-49-address-already-in-use/16469/11 "2024-11-19T11:14:12Z")

</div>

First, _code tags_ (the `</>` button) would make outputs easier to read here.

There is no obvious reason why the process 15241 did exist.

* * *

Now you see a new issue.  
Something does _terminate_ the tac\_plus that the service starts.  
What do its logs say now?

---

<div class="post-metadata">

**Author:** ![Akshay](https://avatars.discourse-cdn.com/v4/letter/a/3ab097/32.png) [@Akshay](https://forums.rockylinux.org/u/Akshay)\
**Post date:** [November 19, 2024, 11:50am UTC](https://forums.rockylinux.org/t/tac-plus-320973-error-get-socket-bind-49-address-already-in-use/16469/12 "2024-11-19T11:50:50Z")

</div>

░░ Subject: A start job for unit tac\_plus.service has finished successfully  
░░ Defined-By: systemd  
░░ Support: [Getting Community Help & Support - Rocky Linux Wiki](https://wiki.rockylinux.org/rocky/support)  
░░  
░░ A start job for unit tac\_plus.service has finished successfully.  
░░  
░░ The job identifier is 43707.  
Nov 19 10:45:37 vm tac\_plus[449997]: Reading config  
Nov 19 10:45:37 vm- tac\_plus[449997]: Version F4.0.4.26 Initialized 1  
Nov 19 10:45:37 vm- tac\_plus[449999]: Received signal 15, shutting down  
Nov 19 10:45:37 vm- systemd[1]: tac\_plus.service: Deactivated successfully.  
░░ Subject: Unit succeeded  
░░ Defined-By: systemd  
░░ Support: [Getting Community Help & Support - Rocky Linux Wiki](https://wiki.rockylinux.org/rocky/support)  
░░  
Here is the log

---

<div class="post-metadata">

**Author:** ![Akshay](https://avatars.discourse-cdn.com/v4/letter/a/3ab097/32.png) [@Akshay](https://forums.rockylinux.org/u/Akshay)\
**Post date:** [November 26, 2024, 12:05pm UTC](https://forums.rockylinux.org/t/tac-plus-320973-error-get-socket-bind-49-address-already-in-use/16469/13 "2024-11-26T12:05:20Z")

</div>

Any help would be appreciated

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/flex020/uploads/rockylinux/original/1X/91b7219eec10e30013422e4df76c1d898711a5d5.svg) [@system](https://forums.rockylinux.org/u/system)\
**Post date:** [January 25, 2025, 12:05pm UTC](https://forums.rockylinux.org/t/tac-plus-320973-error-get-socket-bind-49-address-already-in-use/16469/14 "2025-01-25T12:05:21Z")

</div>

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.
