# SPICE support was dropped in RHEL 9!

**URL:** <https://forums.rockylinux.org/t/spice-support-was-dropped-in-rhel-9/6753>\
**Category:** Rocky Linux Help & Support\
**Created:** [July 27, 2022, 4:22am UTC](https://forums.rockylinux.org/t/spice-support-was-dropped-in-rhel-9/6753 "2022-07-27T04:22:34Z")\
**Posts on this page:** 9\
**Page:** 3

<div class="post-metadata">

**Author:** ![kinu](https://avatars.discourse-cdn.com/v4/letter/k/3ec8ea/32.png) [@kinu](https://forums.rockylinux.org/u/kinu)\
**Post date:** [May 5, 2025, 11:35am UTC](https://forums.rockylinux.org/t/spice-support-was-dropped-in-rhel-9/6753/41 "2025-05-05T11:35:08Z")

</div>

Hello I’m facing this error:  
`Error: Failed instance creation: Failed creating instance record: Instance type "virtual-machine" is not supported on this server: QEMU failed to run feature checks`  
when trying to create/launch a desktop VM in incus.

I have incus 6.12 and spice-gtk-tools installed from the @ligenix repository in Rocky 9.5, and made

`sudo ln -s /usr/libexec/qemu-kvm /usr/bin/qemu-system-x86_64` because incus was asking for /usr/bin/qemu-system-x86\_64

What am I doing wrong?

---

<div class="post-metadata">

**Author:** ![kinu](https://avatars.discourse-cdn.com/v4/letter/k/3ec8ea/32.png) [@kinu](https://forums.rockylinux.org/u/kinu)\
**Post date:** [May 9, 2025, 10:42am UTC](https://forums.rockylinux.org/t/spice-support-was-dropped-in-rhel-9/6753/42 "2025-05-09T10:42:19Z")

</div>

So I’ve been searching out here, and find this:

> **[Launching or starting a VM fails with "... QEMU failed to run feature checks"...](https://gitlab.archlinux.org/archlinux/packaging/packages/incus/-/issues/6)**
>
> Description: Launching a new or starting an existing VM fails (since Incus 6.3) with: Error: Failed instance creation:...

that proposes changes in incus servicel file

Change `Environment=INCUS_OVMF_PATH=/usr/share/ovmf/x64` to `Environment=INCUS_EDK2_PATH=/usr/share/ovmf/x64`

that changes the beaviour. Now I can create the VM, but got an error when trying to start it:

```auto

Error: Failed to run: forklimits limit=memlock:unlimited:unlimited fd=3 fd=4 -- /usr/bin/qemu-system-x86_64 -S -name mydesktop -uuid 79589d61-655e-4123-8120-64de969d6b49 -daemonize -cpu host,hv_passthrough -nographic -serial chardev:console -nodefaults -no-user-config -sandbox on,obsolete=deny,elevateprivileges=allow,spawn=allow,resourcecontrol=deny -readconfig /run/incus/mydesktop/qemu.conf -spice unix=on,disable-ticketing=on,addr=/run/incus/mydesktop/qemu.spice -pidfile /run/incus/mydesktop/qemu.pid -D /var/log/incus/mydesktop/qemu.log -smbios type=2,manufacturer=LinuxContainers,product=Incus -run-with user=nobody: qemu-system-x86_64: -spice unix=on,disable-ticketing=on,addr=/run/incus/mydesktop/qemu.spice: There is no option group 'spice'
: signal: segmentation fault (core dumped)

```

Anyone can help?

---

<div class="post-metadata">

**Author:** ![kinu](https://avatars.discourse-cdn.com/v4/letter/k/3ec8ea/32.png) [@kinu](https://forums.rockylinux.org/u/kinu)\
**Post date:** [May 9, 2025, 11:47am UTC](https://forums.rockylinux.org/t/spice-support-was-dropped-in-rhel-9/6753/43 "2025-05-09T11:47:06Z")

</div>

Ok. Got it working!

I need to install complete thing from @ligenix repository (basically, follow instructions and install virt-manager). So

```auto
dnf install virt-manager
dnf install incus
systemctl edit --full incus.service

```

and change

`Environment=INCUS_OVMF_PATH=/usr/share/edk2/ovmf` to  
`Environment=INCUS_EDK2_PATH=/usr/share/edk2ovmf`

then

`systemctl restart incus`

init the incus instance and you can launch and access desktop VMs!

---

<div class="post-metadata">

**Author:** ![ligenix](https://sea2.discourse-cdn.com/flex020/user_avatar/forums.rockylinux.org/ligenix/32/1285_2.png) [@ligenix](https://forums.rockylinux.org/u/ligenix)\
**Post date:** [May 12, 2025, 7:25pm UTC](https://forums.rockylinux.org/t/spice-support-was-dropped-in-rhel-9/6753/44 "2025-05-12T19:25:10Z")

</div>

Hello kinu, I was offline from my laptop this weekend and a lot busy at work these days.

I added incus to this repository when Michael Stauber from Adventurine asked me to enable virtio-9p in qemu for incus support.

Since then, I’ve been trying to maintain incus as best I can, so any help is welcome.

I just released a new version that fixes the path regression Environment=INCUS\_EDK2\_PATH=/usr/share/edk2ovmf and adds a symlink to /usr/bin/qemu-system-%{\_arch}

---

<div class="post-metadata">

**Author:** ![kinu](https://avatars.discourse-cdn.com/v4/letter/k/3ec8ea/32.png) [@kinu](https://forums.rockylinux.org/u/kinu)\
**Post date:** [May 14, 2025, 11:58am UTC](https://forums.rockylinux.org/t/spice-support-was-dropped-in-rhel-9/6753/45 "2025-05-14T11:58:02Z")

</div>

Thank you very much!

---

<div class="post-metadata">

**Author:** ![scaprile](https://avatars.discourse-cdn.com/v4/letter/s/b5a626/32.png) [@scaprile](https://forums.rockylinux.org/u/scaprile)\
**Post date:** [May 18, 2025, 12:18am UTC](https://forums.rockylinux.org/t/spice-support-was-dropped-in-rhel-9/6753/46 "2025-05-18T00:18:36Z")

</div>

Just decided and moved from Centos Stream 8 to Rocky 8 and then to Rocky 9.  
Now getting ready to have my old VMs working, met this:

```auto
 Problem 2: glib2-2.68.4-14.el9_4.1.i686 from @System does not belong to a distupgrade repository
  - cannot install both glib2-2.69.3-1.el9.x86_64 from copr:copr.fedorainfracloud.org:ligenix:enterprise-qemu-spice and glib2-2.68.4-14.el9_4.1.x86_64 from @System
  - cannot install both glib2-2.68.4-14.el9_4.1.x86_64 from baseos and glib2-2.69.3-1.el9.x86_64 from copr:copr.fedorainfracloud.org:ligenix:enterprise-qemu-spice
  - cannot install the best update candidate for package glib2-2.68.4-14.el9_4.1.x86_64
  - cannot install the best update candidate for package glib2-2.68.4-14.el9_4.1.i686

```

Don’t know how critical is glib2 here so I didn’t dare to skip this package yet.

---

<div class="post-metadata">

**Author:** ![ligenix](https://sea2.discourse-cdn.com/flex020/user_avatar/forums.rockylinux.org/ligenix/32/1285_2.png) [@ligenix](https://forums.rockylinux.org/u/ligenix)\
**Post date:** [May 18, 2025, 8:05pm UTC](https://forums.rockylinux.org/t/spice-support-was-dropped-in-rhel-9/6753/47 "2025-05-18T20:05:54Z")

</div>

`Problem 2: glib2-2.68.4-14.el9_4.1.i686 from @System does not belong to a distupgrade repository`

Hello, try the following dnf command, and if it is correct, run the dnf install again:  
`dnf remove glib2-2.68.4-14.el9_4.1.i686`

---

<div class="post-metadata">

**Author:** ![scaprile](https://avatars.discourse-cdn.com/v4/letter/s/b5a626/32.png) [@scaprile](https://forums.rockylinux.org/u/scaprile)\
**Post date:** [May 18, 2025, 10:05pm UTC](https://forums.rockylinux.org/t/spice-support-was-dropped-in-rhel-9/6753/48 "2025-05-18T22:05:03Z")

</div>

Thx, was delayed fixing networking… I have disabled NetworkManager ages ago since CentOS 7 to have my VMs talk to their host and now interfaces are disabled if not managed…

So the i686 package was causing that… I don’t remember why I have that, I still have old 32-bit packages around so I’ll eventually know if it is necessary, Thanks a lot.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/flex020/uploads/rockylinux/original/1X/91b7219eec10e30013422e4df76c1d898711a5d5.svg) [@system](https://forums.rockylinux.org/u/system)\
**Post date:** [July 17, 2025, 10:05pm UTC](https://forums.rockylinux.org/t/spice-support-was-dropped-in-rhel-9/6753/49 "2025-07-17T22:05:49Z")

</div>

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.

[Previous page](https://forums.rockylinux.org/t/spice-support-was-dropped-in-rhel-9/6753.md?page=2)
