# Setting of 'root' password value fails during Kickstart

**URL:** <https://forums.rockylinux.org/t/setting-of-root-password-value-fails-during-kickstart/3173>\
**Category:** Rocky Linux Help & Support\
**Created:** [June 24, 2021, 11:23pm UTC](https://forums.rockylinux.org/t/setting-of-root-password-value-fails-during-kickstart/3173 "2021-06-24T23:23:30Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![Lothar](https://sea2.discourse-cdn.com/flex020/user_avatar/forums.rockylinux.org/lothar/32/963_2.png) [@Lothar](https://forums.rockylinux.org/u/Lothar)\
**Post date:** [June 24, 2021, 11:23pm UTC](https://forums.rockylinux.org/t/setting-of-root-password-value-fails-during-kickstart/3173/1 "2021-06-24T23:23:30Z")

</div>

Though I believe that it ‘did’ work for the 8.4rc1 installation, I encountered an issue where Kickstart fails (just before reaching the %post process) when attempting to set the ‘root’ password value (as defined in the host-config file).  
It turned out to be an issue identified 4 years ago:  
[https://bugzilla.redhat.com/show\_bug.cgi?id=1469074](https://bugzilla.redhat.com/show_bug.cgi?id=1469074)

If the “selinux=0” setting within the PXE Boot (01- file) isn’t present, along with the “inst.selinux=0” setting, Kickstart doesn’t have the ability to set the value (can’t modify /etc/shadow ?).

When the host-config file is initially accessed by the Kickstart process, it displays the ‘deprecated’ message for any ‘non inst.\*’ values, which is why I had removed the “selinux=0” setting.

If the deprecation is enforced in future releases, will this disable the ability to install the O/S ?

---

<div class="post-metadata">

**Author:** ![brian](https://sea2.discourse-cdn.com/flex020/user_avatar/forums.rockylinux.org/brian/32/5777_2.png) [@brian](https://forums.rockylinux.org/u/brian)\
**Post date:** [August 25, 2023, 4:08am UTC](https://forums.rockylinux.org/t/setting-of-root-password-value-fails-during-kickstart/3173/2 "2023-08-25T04:08:58Z")

</div>


