# RL8-\>RL9 systemd openfortivpn

**URL:** <https://forums.rockylinux.org/t/rl8-rl9-systemd-openfortivpn/9059>\
**Category:** Rocky Linux Help & Support\
**Created:** [March 1, 2023, 6:58pm UTC](https://forums.rockylinux.org/t/rl8-rl9-systemd-openfortivpn/9059 "2023-03-01T18:58:07Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![rlamintegrator](https://avatars.discourse-cdn.com/v4/letter/r/bb73d2/32.png) [@rlamintegrator](https://forums.rockylinux.org/u/rlamintegrator)\
**Post date:** [March 1, 2023, 6:58pm UTC](https://forums.rockylinux.org/t/rl8-rl9-systemd-openfortivpn/9059/1 "2023-03-01T18:58:07Z")

</div>

InPlace upgrade RockyLinux8 to 9 - OK.  
But:  
After ugrade can not start openfortivpn - have permission error about ppp0 and " openfortivpn@cfg1.service: Failed with result ‘timeout’"  
**selinux - disabled… firewall - nftables.**  
In the systemd openfortivpn unit was:  
[Service]  
Type=notify

Now this and all ok :  
[Service]  
Type=simple \<—modify  
PrivateTmp=true  
ExecStart=/usr/bin/openfortivpn -c /etc/openfortivpn/%I.conf  
OOMScoreAdjust=-100  
DeviceAllow=/dev/ppp rw \<—add  
DeviceAllow=/dev/null rw \<—add

I`m don`t know why this… But after sthis steps problem resolved

Serg

---

<div class="post-metadata">

**Author:** ![brian](https://sea2.discourse-cdn.com/flex020/user_avatar/forums.rockylinux.org/brian/32/5777_2.png) [@brian](https://forums.rockylinux.org/u/brian)\
**Post date:** [August 25, 2023, 3:23am UTC](https://forums.rockylinux.org/t/rl8-rl9-systemd-openfortivpn/9059/2 "2023-08-25T03:23:14Z")

</div>


