Problem in upgrade to 4.18.0-425.3.1.el8.x86_64

Hi Pedro,

Below message occur.

  Erasing          : kernel-core-4.18.0-425.3.1.el8.x86_64                  4/4
warning: file /lib/modules/4.18.0-425.3.1.el8.x86_64/updates: remove failed: No such file or directory

  Running scriptlet: kernel-core-4.18.0-425.3.1.el8.x86_64                  4/4

Below error occured, when running the install command.

  Erasing          : kernel-devel-4.18.0-372.16.1.el8_6.x86_64              5/5
  Running scriptlet: kernel-core-4.18.0-425.3.1.el8.x86_64                  5/5
dkms: running auto installation service for kernel 4.18.0-425.3.1.el8.x86_64
Sign command: /lib/modules/4.18.0-425.3.1.el8.x86_64/build/scripts/sign-file
Signing key: /var/lib/dkms/mok.key
Public certificate (MOK): /var/lib/dkms/

Building module:
Cleaning build area...
make -j1 KERNELRELEASE=4.18.0-425.3.1.el8.x86_64 -C /lib/modules/4.18.0-425.3.1.el8.x86_64/build M=/var/lib/dkms/wireguard/1.0.20220627/build...(bad exit status: 2)
Error! Bad return status for module build on kernel: 4.18.0-425.3.1.el8.x86_64 (x86_64)
Consult /var/lib/dkms/wireguard/1.0.20220627/build/make.log for more information.
/etc/dracut.conf.d/virt-drivers.conf:add_drivers+="xen-blkfront xen-netfront virtio_blk virtio_net"

dracut: WARNING: <key>+=" <values> ": <values> should have surrounding white spaces!
dracut: WARNING: This will lead to unwanted side effects! Please fix the configuration file.

  Running scriptlet: kernel-modules-4.18.0-425.3.1.el8.x86_64               5/5
  Running scriptlet: kernel-devel-4.18.0-372.16.1.el8_6.x86_64              5/5
  Verifying        : kernel-4.18.0-425.3.1.el8.x86_64                       1/5

Looks like there is problem from wiregaurd. Therefore dnf remove it.
Re run the dnf remove with below message

  Running scriptlet: kernel-modules-extra-4.18.0-425.3.1.el8.x86_64         2/4
depmod: ERROR: fstatat(4, wireguard.ko.xz): No such file or directory

  Erasing          : kernel-modules-4.18.0-425.3.1.el8.x86_64               3/4
  Running scriptlet: kernel-modules-4.18.0-425.3.1.el8.x86_64               3/4
depmod: ERROR: fstatat(4, wireguard.ko.xz): No such file or directory

Looks like this is due to wireguard removed. Anyway re run dnf install…
There is below message

  Running scriptlet: kernel-core-4.18.0-425.3.1.el8.x86_64                  4/4
/etc/dracut.conf.d/virt-drivers.conf:add_drivers+="xen-blkfront xen-netfront virtio_blk virtio_net"

dracut: WARNING: <key>+=" <values> ": <values> should have surrounding white spaces!

When reboot, the grub menu correctly shown

The problem seems solved! Just hope that the dracut warning message “/etc/dracut.conf.d/virt-drivers.conf:add_drivers…” would not be a problem in future.

Thank you!

THANK YOU everyone that lend a hand on me to solve this problem that I learn a lot in the process.
This is a great community!

1 Like


Run dnf provides */cpio that shows which package you should have for it. Then (re)install it first.

Yeah, that’s the first thing I tried, but cpio is already installed…

@rommel you can solve that really easy, but it’s just a warning.

/etc/dracut.conf.d/virt-drivers.conf:add_drivers+="xen-blkfront xen-netfront virtio_blk virtio_net"

should actually look like:

/etc/dracut.conf.d/virt-drivers.conf:add_drivers+=" xen-blkfront xen-netfront virtio_blk virtio_net "

note the spaces before and after within the quotes. If you edit yours and add these spaces, it will work. I expect in the future the file will be updated anyway, so you can live with the warning, or make the fix like above.

I should probably add a new thread, or submit a bug report. I get a different error message when installing kernel-core-4.18.0-425.3.1.el8.x86_64:

Should I?


As dracut was reporting, even though the cpio package was installed, there was no valid executable. Somehow the cpio installation was corrupted.

I just run

dnf reinstall cpio
dnf reinstall kernel-4.18.0-425.3.1.el8 kernel-core-4.18.0-425.3.1.el8.x86_64

Both completed without complaints, and the system booted fine running kernel-4.18.0-425.3.1.

Thanks all!

In that case, calling it “solved” might not be a good idea.
How did it get corrupted?

Hi Ian,
Yes, after my reply, I edited it. As you said the file will probably be updated, I will try to live with the warning in future. Thanks.

1 Like

My issue is solved because the installation of the kernel returns no errors with the proposed fix. All I know is that the package cpio was installed, but trying to run “cpio” would return “command not found”, and the initramfs could not be generated.

@rommel issue and mine were similar in that both our kernel’s reinstallations failed, but the root of the problems are just different.

my two cents…