# OpenFortiVPN failed to start

**URL:** <https://forums.rockylinux.org/t/openfortivpn-failed-to-start/6504>\
**Category:** Rocky Linux Help & Support\
**Created:** [July 5, 2022, 2:52pm UTC](https://forums.rockylinux.org/t/openfortivpn-failed-to-start/6504 "2022-07-05T14:52:17Z")\
**Posts on this page:** 7\
**Page:** 1

<div class="post-metadata">

**Author:** ![TrapoSAMA](https://avatars.discourse-cdn.com/v4/letter/t/9dc877/32.png) [@TrapoSAMA](https://forums.rockylinux.org/u/TrapoSAMA)\
**Post date:** [July 5, 2022, 2:52pm UTC](https://forums.rockylinux.org/t/openfortivpn-failed-to-start/6504/1 "2022-07-05T14:52:17Z")

</div>

Hi!

after install the package cant check status only enable the service

systemctl enable openfortivpn@  
Created symlink /etc/systemd/system/multi-user.target.wants/openfortivpn@.service → /usr/lib/systemd/system/openfortivpn@.service.

but the stop or status dont work when the @ are in the name, if remove from file and enable the status/stop work.

The other error is in the same file

[Unit]  
Description=OpenFortiVPN for %I  
After=network-online.target  
Documentation=man:openfortivpn(1)

[Service]  
Type=simple  
PrivateTmp=true  
ExecStart=/usr/bin/openfortivpn -c /etc/openfortivpn/%I.conf  
OOMScoreAdjust=-100

[Install]  
WantedBy=multi-user.target

* * *

the %I in descripcion or exec always take blank value. For work the conf file need name .conf

Is possible fix this in the next release?

Thx

---

<div class="post-metadata">

**Author:** ![gerry666uk](https://avatars.discourse-cdn.com/v4/letter/g/dbc845/32.png) [@gerry666uk](https://forums.rockylinux.org/u/gerry666uk)\
**Post date:** [July 5, 2022, 6:19pm UTC](https://forums.rockylinux.org/t/openfortivpn-failed-to-start/6504/2 "2022-07-05T18:19:09Z")

</div>

How did you install it, and did you read the instructions?  
The ‘@’ sign is usually to do with it being a template or using socket activation.  
When using socket activation, the service doesn’t start until someone tries to connect. I’m guessing this is a vpn server that other people can connect to via a network?

---

<div class="post-metadata">

**Author:** ![TrapoSAMA](https://avatars.discourse-cdn.com/v4/letter/t/9dc877/32.png) [@TrapoSAMA](https://forums.rockylinux.org/u/TrapoSAMA)\
**Post date:** [July 5, 2022, 11:28pm UTC](https://forums.rockylinux.org/t/openfortivpn-failed-to-start/6504/3 "2022-07-05T23:28:47Z")

</div>

hi!

i use this software previously and work well in centos and work fine, systemctl start openfortivpn and done

the software is a client for VPN SSL and dont know why need socket activation. Is a simple client in other distros.

In rocky is different? why? please explain.

Thx.

---

<div class="post-metadata">

**Author:** ![chemal](https://sea2.discourse-cdn.com/flex020/user_avatar/forums.rockylinux.org/chemal/32/2238_2.png) [@chemal](https://forums.rockylinux.org/u/chemal)\
**Post date:** [July 11, 2022, 9:14am UTC](https://forums.rockylinux.org/t/openfortivpn-failed-to-start/6504/4 "2022-07-11T09:14:53Z")

</div>

> [@TrapoSAMA](#):
>
> systemctl enable openfortivpn@

You have to type `systemctl enable openfortivpn@NAME`, with _/etc/openfortivpn/NAME.conf_ being the path to your configuration file.

You might want to read [systemd: Template unit files - Fedora Magazine](https://fedoramagazine.org/systemd-template-unit-files/)

---

<div class="post-metadata">

**Author:** ![AlexaThor](https://sea2.discourse-cdn.com/flex020/user_avatar/forums.rockylinux.org/alexathor/32/2076_2.png) [@AlexaThor](https://forums.rockylinux.org/u/AlexaThor)\
**Post date:** [July 11, 2022, 3:43pm UTC](https://forums.rockylinux.org/t/openfortivpn-failed-to-start/6504/5 "2022-07-11T15:43:18Z")

</div>

Were you able to run your VPN after all? Following…

---

<div class="post-metadata">

**Author:** ![TrapoSAMA](https://avatars.discourse-cdn.com/v4/letter/t/9dc877/32.png) [@TrapoSAMA](https://forums.rockylinux.org/u/TrapoSAMA)\
**Post date:** [July 24, 2022, 2:06pm UTC](https://forums.rockylinux.org/t/openfortivpn-failed-to-start/6504/6 "2022-07-24T14:06:02Z")

</div>

Hi!

when the service have the @ only can enable but dont run or check status, if remove the @ can enable, run status and work ok! I see other services with the @ in the name and dont show this issue.

Thx.

---

<div class="post-metadata">

**Author:** ![brian](https://sea2.discourse-cdn.com/flex020/user_avatar/forums.rockylinux.org/brian/32/5777_2.png) [@brian](https://forums.rockylinux.org/u/brian)\
**Post date:** [August 25, 2023, 3:44am UTC](https://forums.rockylinux.org/t/openfortivpn-failed-to-start/6504/7 "2023-08-25T03:44:33Z")

</div>


