# Migrated from CentOS but cannot find the telnetd after adding telnet-server rpm

**URL:** <https://forums.rockylinux.org/t/migrated-from-centos-but-cannot-find-the-telnetd-after-adding-telnet-server-rpm/14925>\
**Category:** Rocky Linux Help & Support\
**Tags:** rocky-linux-9\
**Created:** [July 4, 2024, 8:32pm UTC](https://forums.rockylinux.org/t/migrated-from-centos-but-cannot-find-the-telnetd-after-adding-telnet-server-rpm/14925 "2024-07-04T20:32:48Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![marcatsamco](https://avatars.discourse-cdn.com/v4/letter/m/ad7895/32.png) [@marcatsamco](https://forums.rockylinux.org/u/marcatsamco)\
**Post date:** [July 4, 2024, 8:32pm UTC](https://forums.rockylinux.org/t/migrated-from-centos-but-cannot-find-the-telnetd-after-adding-telnet-server-rpm/14925/1 "2024-07-04T20:32:48Z")

</div>

Hi,

I migrated from CentOS 7, but I cannot find the telnetd after installing telnet-server rpm on Rocky 9. Am I missing something. Thanks in advance, Marc.

---

<div class="post-metadata">

**Author:** ![iwalker](https://sea2.discourse-cdn.com/flex020/user_avatar/forums.rockylinux.org/iwalker/32/2599_2.png) [@iwalker](https://forums.rockylinux.org/u/iwalker)\
**Post date:** [July 4, 2024, 9:01pm UTC](https://forums.rockylinux.org/t/migrated-from-centos-but-cannot-find-the-telnetd-after-adding-telnet-server-rpm/14925/2 "2024-07-04T21:01:25Z")

</div>

Is there a reason for running `telnetd` especially since telnet is insecure. Usually remote connections to a server would be done over SSH instead - far more secure, encrypted. Telnet isn’t.

The telnet-server package has the following files:

```auto
root@rocky9 ~]# dnf repoquery -l telnet-server

/usr/lib/.build-id
/usr/lib/.build-id/39
/usr/lib/.build-id/39/ead747a97485726d76317825cd6785a296d8dc
/usr/lib/systemd/system/telnet.socket
/usr/lib/systemd/system/telnet@.service
/usr/sbin/in.telnetd
/usr/share/man/man5/issue.net.5.gz
/usr/share/man/man8/in.telnetd.8.gz
/usr/share/man/man8/telnetd.8.gz

```

then you would just do `systemctl start telnet` to get the server running. And use `systemctl enable telnet` to ensure it’s running on each server reboot.

---

<div class="post-metadata">

**Author:** ![marcatsamco](https://avatars.discourse-cdn.com/v4/letter/m/ad7895/32.png) [@marcatsamco](https://forums.rockylinux.org/u/marcatsamco)\
**Post date:** [July 4, 2024, 9:51pm UTC](https://forums.rockylinux.org/t/migrated-from-centos-but-cannot-find-the-telnetd-after-adding-telnet-server-rpm/14925/3 "2024-07-04T21:51:02Z")

</div>

I have old devices that use only telnet to access the server’s app inside the network and from site VPN connections.

When I ran the command to start the telnet service I got the following errors:

* * *

[root@rockytst ~]# systemctl start telnet  
Failed to start telnet.service: Unit telnet.service not found.

## [root@rockytst ~]# systemctl enable telnet Failed to enable unit: Unit file telnet.service does not exist.

The above failures gave a clue on extra steps to be done. So, I ran the following:

```auto
$ sudo systemctl enable telnet.socket

to startup the service on servier bootup/startup. and,

$ sudo systemctl start telnet.socket

to manually start the telnet service 

```

to test,

$ telnet localhost  
Trying ::1…  
Connected to localhost.  
Escape character is ‘^]’.

Kernel 5.14.0-70.13.1.el9\_0.x86\_64 on an x86\_64  
samco login:

Thanks for you help.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/flex020/uploads/rockylinux/original/1X/91b7219eec10e30013422e4df76c1d898711a5d5.svg) [@system](https://forums.rockylinux.org/u/system)\
**Post date:** [September 2, 2024, 9:51pm UTC](https://forums.rockylinux.org/t/migrated-from-centos-but-cannot-find-the-telnetd-after-adding-telnet-server-rpm/14925/4 "2024-09-02T21:51:42Z")

</div>

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.
