# FreeIPA: kinit error

**URL:** <https://forums.rockylinux.org/t/freeipa-kinit-error/18721>\
**Category:** Rocky Linux Help & Support\
**Created:** [June 9, 2025, 5:50am UTC](https://forums.rockylinux.org/t/freeipa-kinit-error/18721 "2025-06-09T05:50:37Z")\
**Posts on this page:** 6\
**Page:** 1

<div class="post-metadata">

**Author:** ![himori](https://avatars.discourse-cdn.com/v4/letter/h/6de8d8/32.png) [@himori](https://forums.rockylinux.org/u/himori)\
**Post date:** [June 9, 2025, 5:50am UTC](https://forums.rockylinux.org/t/freeipa-kinit-error/18721/1 "2025-06-09T05:50:37Z")

</div>

I am using Locky 9.5.  
I installed FreeIPA, but I am having trouble with the following error.

(if I put in the wrong password)  
[root@rocky ~]# kinit username  
Password for [username@XXXXXX.COM](mailto:username@XXXXXX.COM):.  
kinit: Password incorrect while getting initial credentials

(if you put in the correct password)  
[root@rocky ~]# kinit username  
Password for [username@XXXXXX.COM](mailto:username@XXXXXX.COM):  
kinit: Generic error (see e-text) while getting initial credentials

Why do I get an error even if I put in the correct password?  
What should I do to solve this problem and how?

–  
himori

---

<div class="post-metadata">

**Author:** ![label](https://avatars.discourse-cdn.com/v4/letter/l/c5a1d2/32.png) [@label](https://forums.rockylinux.org/u/label)\
**Post date:** [June 9, 2025, 5:56am UTC](https://forums.rockylinux.org/t/freeipa-kinit-error/18721/2 "2025-06-09T05:56:29Z")

</div>

If this is a brand new installation, you should not be having these issues. Is this a standard install? Did you turn off or on any settings during or after installation?

With those questions in mind, you need to start troubleshooting by piping the kerberos debug into stderr.

```bash
% KRB5_TRACE=/dev/stderr kinit username@REALM

```

This will produce output for you to read through to help you determine your next steps in troubleshooting.

---

<div class="post-metadata">

**Author:** ![himori](https://avatars.discourse-cdn.com/v4/letter/h/6de8d8/32.png) [@himori](https://forums.rockylinux.org/u/himori)\
**Post date:** [June 9, 2025, 6:49am UTC](https://forums.rockylinux.org/t/freeipa-kinit-error/18721/3 "2025-06-09T06:49:45Z")

</div>

Solved!

# ipa user-del username

# ipa user-add username --password

# kinit username

It’s OK!

---

<div class="post-metadata">

**Author:** ![himori](https://avatars.discourse-cdn.com/v4/letter/h/6de8d8/32.png) [@himori](https://forums.rockylinux.org/u/himori)\
**Post date:** [June 9, 2025, 7:02am UTC](https://forums.rockylinux.org/t/freeipa-kinit-error/18721/4 "2025-06-09T07:02:12Z")

</div>

Thank you for your advise.

---

<div class="post-metadata">

**Author:** ![himori](https://avatars.discourse-cdn.com/v4/letter/h/6de8d8/32.png) [@himori](https://forums.rockylinux.org/u/himori)\
**Post date:** [June 11, 2025, 1:25am UTC](https://forums.rockylinux.org/t/freeipa-kinit-error/18721/5 "2025-06-11T01:25:18Z")

</div>

Recreating users is not a necessary requirement,  
It appears that the following information has been performed and the user is now able to log in.

> **[Red Hat Identity Management をアップグレードした後、Kerberos を使用して認証できない - Red Hat...](https://access.redhat.com/ja/solutions/7092719)**
>
> ipa-server を 4.10.1-3 以降に更新すると、ドメインユーザーは Kerberos でログインできなくなります。 $ kinit test Password for test@EXAMPLE.COM: kinit: Generic error (see e-text) while getting initial credentials /var/log/krb5kdc.log の KDC ログに次のエラーが表示される可能性があります。 May 25 10:19:05...

> **[Cannot authenticate using Kerberos after upgrading Red Hat Identity Management...](https://access.redhat.com/solutions/7015184)**
>
> After updating ipa-server to 4.10.1-3 or newer, domain users cannot login anymore with Kerberos. $ kinit test Password for test@EXAMPLE.COM: kinit: Generic error (see e-text) while getting initial credentials KDC logs in /var/log/krb5kdc.log might...

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/flex020/uploads/rockylinux/original/1X/91b7219eec10e30013422e4df76c1d898711a5d5.svg) [@system](https://forums.rockylinux.org/u/system)\
**Post date:** [August 10, 2025, 1:25am UTC](https://forums.rockylinux.org/t/freeipa-kinit-error/18721/6 "2025-08-10T01:25:53Z")

</div>

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.
