CentOS Refusenik Needs Help

A quick introduction.I am an EX-CentOS user. I have been using Linux for about 21 + years. I am a retired Ph.D. level Research Scientist who for a “Hobby” tracks Newly Emerging Infectious Diseases. I have Parkinson’s Disease, and while I am not afraid the the CLI tend to use a GUI and the CLI about equally, and use Midnight Commander (mc) to avoid having to type which is a bit problematic for me.

I have a new Workstation based around an AMD 5900X CPU with 64GB of RAM. I am in the process of searching for a NEW OS. I am also a KDE user. I realize that Rocky Linux is a bug-for-bug copy of RHEL, but it still is/was possible to install KDE on CentOS 8.3, even if you had to jump through a number of hoops to do so. Rocky Linux is on my short list of replacement OS’s for CentOS.

I was on CentOS for so long (Since CentOS 5.x) I knew all the repos. Is Rocky Linux going to use the same repos that CentOS used/uses, or will you use different repos? Will there be some way to install KDE on Rocky Linux 8.4 Stable, and if so, how would I do it?? KDE is one of a handful of apps that is a “must have” for both my buddy and myself.

I learned just this week that my timetable to finish evaluating a replacement OS for CentOS just got further squeezed as CentOS 8.5 will hit the End of the Line on 12/31/21, and I have to have answers for my buddy and myself long before then.

Any help and or guidance you can provide would be greatly appreciated.


D’ Cat


Being as KDE works on centos 8, there’s no reason it shouldn’t work on Rocky. These instructions should work fine on rocky:

Thanks Tom.

?!?!? So you are saying that Rocky Linux uses the same repos and dnf commands as CentOS?!? If so that would indeed be good news and would make migrating to Rocky Linux 8.4 Stable a piece of cake.

I hope to start the install of RL 8.4 S a week from now if not before. I have a thumb drive with RL 8.4 S on it but need to clean and re-format the NVMe 4.0 drive first before I do the install. Does Rocky use the Anaconda installer??

Thank you for answering what seems like incredulous questions.


Any repo for centos 8, should be usable in rocky.



Not migrated centos running a desk environment yet, but I can’t see any reason why kde should cause an issue.


Thanks Tom.

A few notes from my rather modest experiences with Rocky . . .

The two main repos for Rocky 8.4 are:

Rocky uses DNF
Rocky uses the Anaconda installer

I converted a Centos 8 system to Rocky very easily - see this thread Transition from CentOS to Rocky - #37 by Iainwhite

Thanks!! Maybe over the weekend I’ll scrub and reformat my NVMe 4.0 drive, and prepare to do a fresh install of Rocky Linux. This might be a Super Easy. We’ll see.

1 Like

HUMMMMMM. I scrubbed the NVMe 4.0 drive and prepped for the install. Feeling good and having the thumb-drive on hand I threw caution to the wind and proceeded to TRY and install Rocky Linux 8.4 Stable. It did not go well. I TRIED to do a CUSTOM Install – no LVM, but good Ol’ partitions. That part went well. I then hit the button to do the INSTALL. The first part of the Install went well, and then it decided started to download (?) the packages. The first few packages went well and then it hit one package, and up popped a message about an rpm package that it could not install and it was fatal and could not proceed further. I repeated the Custom Install in various ways but it would get to this one point and freeze yielding the same rpm package it could not install and that it was fatal and could not proceed.

After cleaning and re-scrubbing the NVMe drive more than a few time I threw in the towel and did a Custom LVM install. I hate LVM, but anything to get Rocky 8.4 stable installed. The Install sailed right on through, and I gave a sigh of relief. Oh well you can’t have everything. I then re-booted the machine and instead of getting a typical login screen all I got was a blinking cursor!! So while the Rocky 8.4 Stable LVM Install sailed right on through, in the end it too proved that it could not boot.

Has anyone had problems doing a Custom Install using Classic Partitioning or a Custom Install using LVM and then having it hang with a blinking cursor?

Final Question: What is the difference between Rocky Linux 8.4 BaseOS and Rocky Linux 8.4 Stable? The file and the thumb-drive seem to be fine and I did a media test and nothing was flagged. I downloaded a NEW copy of Rocky Linux but it says Rocky Linux 8.4 STABLE not BaseOS.

If you have any idea what is wrong, please let me know.


It would get to this one point and freeze yielding the same rpm package it could not install and that it was fatal and could not proceed.

Which package?

I then re-booted the machine and instead of getting a typical login screen all I got was a blinking cursor!!

When you say a blinking cursor, do you just mean the console login screen? Did you see any boot messages?

What is the difference between Rocky Linux 8.4 BaseOS and Rocky Linux 8.4 Stable?

These are not comparable. BaseOS is just the name of the repository that provides core packages.

I expect you didn’t choose the “Server with GUI” option when installing, so you did a basic/minimal install which left you with a console screen and login option? Alternatively, if there is just a blinking cursor with nothing else, then perhaps press ESC and see if it shows any messages on the screen as it could potentially have frozen on something during the boot process. Or, maybe has attempted to run the GUI environment but got stuck because of a driver issue.

So plenty of possibilities, just need more info from you on that?

[ Quote] I expect you didn’t choose the “Server with GUI” option when installing, so you did a basic/minimal install which left you with a console screen and login option? Alternatively, if there is just a blinking cursor with nothing else, then perhaps press ESC and see if it shows any messages on the screen as it could potentially have frozen on something during the boot process. Or, maybe has attempted to run the GUI environment but got stuck because of a driver issue. [\Quote]

Actually I DID choose “Server with GUI” and built out from there by including additional packages. Thinking the problem might be with those additional packages I stripped it down to the bare "
“Server with GUI” with the intent of doing a yum / dnf grouplist followed by a yum /dnf groupinstall “xyz”. No GO!!

Next stop was to choose the Custom LVM option with the MINIMAL “Server with GUI” . That went in!! But when I rebooted the machine all I got was the blinking cursor – it was severely hung.

Today I was back at it again. I downloaded fresh copies of both Rocky Linux 8.4 Stable and CentOS 8.4 (as a work around ) and got the cursed "The following error occurred… DNF error while unpacking rpm package [package xyz name] (See my latest post). Just in case the problem involved the “Server with GUI” packaging I installed the “Workstation” with the intent of back-filling of any additional packages.

The ONLY thing I did not install was a “MINIMAL” install – I’ve done that before but with disastrous results – I learned my lesson. That said I might do it just as an “experiment”.

My graphics card is a rather vanilla Nvidia GeForce GT 730 [don’t ask: I need a card with at least one VGA port as I run a 4 machine network and I have a VGA KVM switch – it gets the job done].

My conclusion is this: Given that Rocky Linux 8.4 Stable is a bug-for-bug copy of RHEL 8.4 and I was able to prove that I had the EXACT SAME PROBLEM while trying to do an install of CentOS 8.4 could suggest that the problem is software related. Mind you I CentOS 8.3 running on the same NVMe 4.0 drive until a disaster struck and screwed up the install. The NVMe 4.0 drive was scrubbed clean ie all old files and directories were deleted using GParted, before I did any install.

The other conclusion is that the NVMe 4.0 drive is too fast for the install process. I had put CentOS 8.3 on that drive when I still had an AMD Ryzen 3 2200 4 core 4 thread CPU installed, not the current AMD Ryzen 9 5900X 12 Core 24 Thread CPU which, trust me, is a speed demon (yes I was able to find one though I paid a $50 premium. Better than the $150 -$250+ that is typical on Ebay).

The speed of the CPU would be the final factor I can think of.

As a TEST I might install a junker distro like Manjaro or Mint just to see if they will install, if they DO with out problem this might be one of those bug-for-bug carryovers from RHEL.

Hi Brian,

I mispoke. Yesterday I was hardheaded and kept trying to install and I would get the following message:

"Following error occurred while installing: This is a fatal error and installation will be aborted. DNF error while unpacking rpm package [name of package] ".

Yesterday I did not notice which package, TODAY I noticed that the rpm package changed each time. Yesterday all I noticed was the cursed message, and failed to note the package. (See today’s post)

Yesterday I lucked out to get the LVM option to make it through; today I did not. Even with either the Custom LVM option selected or the automatic install enabled I got the cursed “The following error occurred” message. This might explain why I got the blinking cursor. To answer your question I never made it to the login screen. I did not see any boot message.


Are you able to try on a different hard drive?

Thanks Tom.

Actually that is my next step: I have a small 250 GB SSD I plan to pull out of a case and temporarily install in my new workstation. Today i have spent most of the day downloading new copies of CentOS 8.4, Rocky Linux 4 Stable, Manjaro 21.0.7, and Linux Mint 20.2. I stopped the test on Linux Mint as it said it wanted to install it along side of an older copy of Rocky Linux, (on a separate disk I don’t want to overwrite) and openSUSE 15.3 which is yet on another disk I don’t want to overwrite, leaving the NVMe 4.0 drive which ultimately is where THE OS will be installed.


Quick update: My experiment with Manjaro just FAILED even with it installing in AUTOMATIC mode ( I was about to copy the error message in via cut-n-paste but forgot I’m on two different computers.

I’d better go to bed and rise up to fight another day!!

1 Like

I’m not nearly as experienced as you and I’m having issues that may be similar.

The item that caught my eye in your post was “Nvidia GeForce GT 730”. I’m seeing issues with RL 8.4 on my brand-spanking-new Dell XPS 8940 that appear to related to the NVidia drivers. Other web sources suggest that NVidia apparently provides closed- rather than open-source drivers, and those in turn may have issues involving signing and such.

A particularly annoying issue I’m seeing is with “nouveau”, apparently some sort of alternative to the NVidia driver. My system is crashing after being idle for 15-30 minutes. When it crashes, it is unable to gracefully finish its shutdown because some issue with nouveau prevents Kernel shutdown from finishing gracefully.

I’m eager to hear what you learn in your investigation.

BTW, the main project I’m working on is a COVID data browser for visualizing death and case counts, vaccination rates, hot-spot predictions, and so on by county. I invite you (or anybody else who is interested) to explore it at http://covid.zeetix.com

@SomervilleTom Yep, that is what I hinted at in my post that a blinking cursor usually means the graphic driver isn’t working correctly. It won’t be a software issue since it works for the most, but it’s something with this hardware that is causing the problems.

Doing a minimal install, if the login prompt then appears would then mean that the GUI environment is the problem.

Hi Tom

HUMMMMMMM. Nouveau. I *sort" of remember that a while back. I’ll need to look into that, as that happened a while back but figure out if that was the problem it had been solved, or if it was the solution to a problem. I sort of remember it involved adding or removing a line I think in the boot process. You can probably find it in the CentOS forums. Right now we are in the middle of the Monsoon Season which I call the Migraine Season as I take drugs to keep me from crawling up the wall – or worse! Half the time I am stoned, and if it is REALLY bad I wake up take some more medicine, then go back to sleep. The worse Migraine I ever had lasted 72 hours and I was hitting the Fiorinal every 4 hours. It took over a week to “dry out”. But thank you for reminding me of Nouveau.

As to the Nidia GeForce GT 730… I know there is a GeForce GT1xxx that I’m thinking in buying. I bought the GT 730 ONLY because it had VGA which I need, though I later learned that there is a GT 1xxx that has a VGA port on it.

As to DELL… With due respect I would not buy ANYTHING from Dell – they are frequently overpriced, under powered, and obsolete when you buy them, pieces of crap. I’d be shocked if it has a PSU that is greater than 400W. I know, as my sister has has several of them, and guess who had to FIX them? They all came with either a 200W PSU or 250W PSU and Dell’s GoTo graphics card is the GeForce GT730. If you bought an ACTUAL WORKSTATION from them, you probably paid in excess of $2,000. I actually tore one of their computers apart after my sister managed to murder the case (don’t ask, it was unbelievable) and I got to study everything about that computer: The motherboard and associated stuff were all made in China, and bottom end parts – read CHEAP! – the parts were then sent to Mexico where the computer was assembled, and it was registered in Ireland, probably for Tax purposes. Depending on the parts you choose, you could BUILD a far better computer than whatever you bought from Dell for far less $$$. I just built my current workstation with an ASUS Prime X570 Pro motherboard, 64 GiB of GSkill Trident Z Neo DDR4 RAM (expandable to 128 GiB) , an AMD Ryzen 9 5900X CPU (IF you can find one – it took me 9 months to located one ), a DVD player, Push/Pull CPU air cooled cooler, a Corsair 750 W PSU, and a GeForce GT 730 Graphics card, a 1TB Corsair NVMe 4.0 SSD, 1 TB, 2.5" SSD; and a 2 TB HHD, all housed in a Corsair Carbide 200R case for about $1,500 – $1,750 ( ~ $1,000 was between the CPU – $599 – and the RAM – ~ $300+ ).

Depending on the size of the case (my sister has one of Dell’s “mini towers” ) if it has a good size case check the size of the PSU and consider upgrading, if possible, as Dell uses a lot of proprietary parts that can’t be swapped out for off the shelf parts, then upgrade the graphics card. The limiting factor on a lot Dell equipment is the PSU, and frequenting the amount of installable RAM.

I’ve been on top of of SARS-CoV-2, aka CoViD-19 when it was still called the Wuhan Virus. Before that it was Ebola, and before that Dengue, Cholera, etc. – Hey everybody needs a “Hobby”!! Sadly I seriously doubt the Delta version of CoViD 19 will be the last we see of it – I suspect it is going mutate faster than we can vaccinate, that might render our current vaccines impotent in their ability to protect against it, only the next mutate will spread faster and be deadlier than the previous mutant. It is simply a numbers game, until you reach a point that the “herd” has been significantly been “thinned out” where the virus can’t reach the next host, thus dying out. And in population of 7.4 BILLION people… One thing you might want to do is plot global deaths and death by country and morbidity by variant to see where that point might be. If you have access to a decent workstation and may be SAS or “R”… or access to and time on a university Super Computer – As diseases go this is rather MILD roughly 3.5 to 4% mortality, though the morbidity rates are far, far higher. Compare that to Ebola Zaire with a mortality rate of roughly 90%. I have up to 20 Virtual Desktops at times where I tract all this data. I think it is time to throw up my data screens once again – I had taken them down around April… Hey everybody needs a Hobby!

At some point I’m going to check out Nouveau and see if I can dig it up. A lot depends when I am awake, and not raining. If you find out that info before I do please post. I have a lot of head scratchers. Stuff that runs on my current workstation refuses to run on on ocelot. Today I found and threw in the wimpy 250GB 2.5" SSD . I start experimentation with it tomorrow… or the day after… or

Stay in touch.


HUMMM though in my case it either blinked… and never stopped blinking – but this ONLY happened during the install and the reboot. On other installs openSUSE 15.3 or even the earlier version of Rocky Linux 8.3… that is segregated on 1 TB SSD not the 1TB NVMe 4.0 SSD I have no problem. If it is a HW problem then the problem has to do with the NVMe 4.0 drive, but I have CentOS 8.3 running on it.

Dug out the 250 GB 2.5" SSD and will try and throw RL on that. This is a head scratcher.

openSUSE 15.3 has kernel 5.3.x which is far newer than what is in Rocky - 4.18.0 so it cannot be compared since later drivers are available in the newer kernel.

My son has an ASUS laptop with Ryzen 5 and Intel/AMD dual graphics. In Linux Mint, we could never get the ATI driver to work properly. And yet, with Fedora 32 it worked a dream. Again, since newer packages, newer kernel etc. So this is a similar situation I think.

The only issue I don’t understand is why CentOS 8.3 worked, and then 8.4 doesn’t. Perhaps the NVIDIA driver in 8.3 supported your card, and now it doesn’t in an updated one (can happen if the card is quite old - which then requires using older NVIDIA drivers than the newer ones). Obviously a regression or something changed relating to the NVIDIA drivers causing a problem for your particular card. If you did a minimal install, without the Server GUI and selecting any other options, if after reboot you get the console login screen, that means Rocky in a minimal state is fine, and that the problem is related to Wayland and the NVIDIA drivers.

BTW maybe this might make some sense to someone: During my various fresh installs this was the message I got:

The following error occurred while installing. This is a FATAL ERROR and installation will be aborting. DNF error unpacking. rpm package: [Name of package]

Here are some of the ones that came up:


The exact point it threw the hissy fit varied upon which distro I was using (CentOS 8.4, Rocky Linux 8.4 Stable, or Manjaro 21.0.7) and the installation type (Classic Partitioning, Partitioning with LVM, or Automatic installation.

Hardware Problems: CentOS 8.3 went on the NVMe 4.0 drive but not, CentOS 8.4 or Rocky Linux 8.4 Stable.

Rocky Linux 8.3 went on a 1 TB 2.5" SSD.

openSUSE 15.3 installed on a 2 TB HHD. Reinstalled at least once.

Variables (?) The ONLY thing that might be attributed to the NVMe 4.0 was after the CentOS 8.3 install went south due to operator error I scrubbed the disk using GParted. Once everything has been cleaned there is a header called PARTITION under which appears UNALLOCATED. Next to that there is a header that says FILE SYSTEM under which appears UNALLOCATED. Next to that is a header that says SIZE and under that is 931.51 GiB

HUMMMMMM I WONDER if there has to be an assigned File System rather than being left “UNALLOCATED” ? Though usually after you go through the song and dance and install the OS that will says something like Ext4, LVM, Xfs, etc. If I click on DEVICE at the very top and if I click on that it says “CREATE PARTITION TABLE” and if you click on that it says " Select new partition type" and the DEFAULT is MSDOS. I WONDER IF somehow I need to FORMAT the drive BEFORE I proceed to the installation but that would be rather repetitive as the drive will be formatted anyway during the course of the install.

That then is the ONLY VARIABLE I can come up with. IF the drive has to be PRE-FORMATTED BEFORE one does the install how does one do that?? Any idea where I may be going WRONG?!?

SIGH!!! I may need to do that cursed thing with the minimal install that last time I tried that a few years ago, it ended badly. But proof of concept… Thought you did answer one question: why openSUSE 15.3 works so well. My buddy is leaning towards openSUSE because it comes with KDE as the default for our new OS. Linux Mint I had troubles with – the installer is definitely not ready for Prime Time – for a Linux Newbie with only one machine you really can’t screw it up too bad, but with a network – even a small network of 4 computers and several drives – not knowing exactly what it wants to erase or wants to install next to is scary. There is a reason I keep my OS’s segregated to separate drives and I don’t want some auto installer making my decisions for me. You also gave me yet another idea: Fedora a test subject. Ant rate off to bed. Tomorrow I live to fight another day.