# Cannot activate service in Rocky 8.6

**URL:** <https://forums.rockylinux.org/t/cannot-activate-service-in-rocky-8-6/8088>\
**Category:** Rocky Linux Help & Support\
**Created:** [November 30, 2022, 3:31pm UTC](https://forums.rockylinux.org/t/cannot-activate-service-in-rocky-8-6/8088 "2022-11-30T15:31:39Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![DW3dp](https://avatars.discourse-cdn.com/v4/letter/d/a587f6/32.png) [@DW3dp](https://forums.rockylinux.org/u/DW3dp)\
**Post date:** [November 30, 2022, 3:31pm UTC](https://forums.rockylinux.org/t/cannot-activate-service-in-rocky-8-6/8088/1 "2022-11-30T15:31:39Z")

</div>

Hi,

We have problems installing and rpm package that on Centos worked perfectly so we don’t know if the problem is more service or rpm packages in Rocky related. any help is much appreciated

We are installing an rpm package that copies a service (and other files) into the /usr/lib/systemd/system/ServiceName.service  
but when we check using the systemctl status ServiceName.service

we get

```auto
Loaded: loaded (/usr/lib/systemd/system/ServiceName.service; disable; vendor preset disabled)
Active: failed (Result: exit-code) since Tue 2022-11-29)
MAIN PID:1826 (code = exited, status=203/EXEC)

systemd[1]: ServiceName.service: Service RestartSec=100ms expired, scheduling restart.
systemd[1]: ServiceName.service: Scheduled restart job, restart counter is at 5.
systemd[1]: Stopped
systemd[1]: ServiceName.service: Start request repeated too quickly
systemd[1]: ServiceName.service: Service RestartSec=100ms expired, scheduling restart.
systemd[1]: ServiceName.service: Failed with result 'exit-code'.
systemd[1]: Failed to start

```

---

<div class="post-metadata">

**Author:** ![label](https://avatars.discourse-cdn.com/v4/letter/l/c5a1d2/32.png) [@label](https://forums.rockylinux.org/u/label)\
**Post date:** [November 30, 2022, 3:55pm UTC](https://forums.rockylinux.org/t/cannot-activate-service-in-rocky-8-6/8088/2 "2022-11-30T15:55:53Z")

</div>

`203/EXEC` is likely saying that the process you’re trying to start (on `ExecStart`) is not executable. If this is a custom package, you will need to make sure that the binaries/scripts/etc that are going to be executed through systemd have the executable bit set.

---

<div class="post-metadata">

**Author:** ![brian](https://sea2.discourse-cdn.com/flex020/user_avatar/forums.rockylinux.org/brian/32/5777_2.png) [@brian](https://forums.rockylinux.org/u/brian)\
**Post date:** [August 25, 2023, 3:32am UTC](https://forums.rockylinux.org/t/cannot-activate-service-in-rocky-8-6/8088/3 "2023-08-25T03:32:32Z")

</div>


